No line wraps if last line of the screen buffer is reached

Apr 15, 2013
7
0
If the last line of the screen buffer is reached, TCC doesn't wrap long lines that exceed the number of characters per row but continues at the beginning of the current line. At least, this happens with the demo version of TCC v26.
To reproduce this, you can set the screen buffer size to 20, for example, press Return 20 times, and type in some random text. The characters at the beginning of the last line are overwritten, as shown in the screen recording. Is this intentional or a bug?

tcc-nowrap.png
 
May 20, 2008
10,631
81
Syracuse, NY, USA
Does the same thing happen with CMD ... with PowerShell?

What version of Windows is running? If it's Windows 10, are you using the enhanced console or the legacy console?
 
Apr 15, 2013
7
0
No, that doesn't happen with CMD or PowerShell. It also doesn't matter whether I start TCC directly in the legacy console or in the new Terminal. The screen recording above shows the legacy console (TCC started by calling tcc.exe from the start menu).
I'm using Windows 10,1909
Are you not able to reproduce it?
 
May 20, 2008
10,631
81
Syracuse, NY, USA
I'm using this (below) and I cannot reproduce it. I use the console; that is, the newer, enhanced console (as opposed to the legacy console, available under Properties\Options). I also tried with Windows Terminal and could not reproduce it.

Code:
TCC  26.02.41 x64
Microsoft Windows 10 Pro for Workstations
10.0.18363.959 (1909)
 

rconn

Administrator
Staff member
May 14, 2008
11,926
133
This is a Windows bug, not TCC. Windows is handling the display, and it is failing to scroll (CMD and Powershell use a different API to write output, which is why they behave differently).

I'll try to come up with a kludge-around for the next build; in the meantime you can tell TCC to use something other than the default color for output. That will make TCC handle the display output instead of Windows, and TCC knows to scroll at the end.
 
Apr 15, 2013
7
0
Thank you for the investigation and the confirmation of the issue. I'll try your suggested workaround to set an explicit output color.