Welcome!

By registering with us, you'll be able to discuss, share and private message with other members of our community.

SignUp Now!

Open properties for .LNK?

May
13,044
176
Is there a TCC built-in way to open the properties dialog for a shortcut ... could it be done with @WINAPI[]?
 
This seemed to work for me:

Code:
@winapi[shell32.dll, ShellExecute, NULL, "properties", "Test.lnk", NULL, NULL, 1]
 
Works here too. Sweet!
The @WINAPI one worked on a LNK. On an EXE it failed, returning 31 - a device attached to the system is not functioning. (???) It fails similarly on a drive or folder.

Thanks Charles for reminding me about SHELLEX. I must have known at one time that it could open "Properties" because it's help mentions that fact. It works for files of various types as well as drives and folders.

I did find code for an old (also SysUtils) plugin "PROPS" ... most of it I found on the web ... absolutely horrendous ... does everything with bare hands and adds 6KB to the SysUtils binary! I think I'll write a new PROPS that uses SHELLEX ... ought to be just a handful of lines.
 
And I discovered that, like START, SHELLEX works with objects specified as "shell:object". For example,
Code:
v:\> shellex shell:controlpanelfolder
 
v:\> shellex /c /v properties shell:desktop
 
Sorry, Vince, your first line is displayed with an emoticon in what may be the word "shell:object" ... XenForo [un]help does not show any means to display the true text, not its interpretation as smilies...
 
Yeah, my own message now displays the same smilie, replacing the sequence ":" "o". Now I know your message had "shell:" followed by "object" but was misinterpreted by XenForo and displays only the smilie instead...
 
Yeah, my own message now displays the same smilie, replacing the sequence ":" "o". Now I know your message had "shell:" followed by "object" but was misinterpreted by XenForo and displays only the smilie instead...
Just ducky! Give me emoticons! To hell with accurate communication.
 
XenForo forum suggestion: - instead of Rex'
Code:
. Both depend on the poster knowing in advance what character sequences may be considered as emoticons (a continually expanding world).

I just checked "hide smilies" in my preferences. As Vince noted, it has not taken effect. I'll post this, and close the Firefox tab, and reopen th thread in a new tab to see and report what happens.
 
OK, I just reopened this thread in a new tab of the same old instance of Firefox 16.0.1, and now the original text is properly legible and not converted to an emoticon. BTW, in another tab of the same Firefox instance I remained logged into the Forum. Closing just the single tab and reopening it was sufficient.
 
Back
Top
[FOX] Ultimate Translator
Translate