perl output is not visible

Nov 19, 2014
9
0
When I run a perl script in the editor I am not seeing the output. When I run cmd inside the same shell the output from the perl script appears fine.

IE:

build.pl
<nothing>

cmd.exe
build.pl
<output appears here>

My co-worker who is also using Take Command is not seeing this.
Does anyone have any ideas what this might be?
 

rconn

Administrator
Staff member
May 14, 2008
12,340
149
I'n unclear what "IE" has to do with this?

Do you have the internal TCC Perl scripting support enabled? (OPTION / Startup / Scripting.) If so, you must be using PerlScript (because there are waaaaay too many bugs in the embedded Perl for Windows). If you're not using PerlScript, then disable that option.
 
Similar threads
Thread starter Title Forum Replies Date
vefatica Documentation TPIPE, /perl, DotMatchesNewLines Support 1
David McClelland TCMD 24 & Perl - perl thinks it's own executable is ...\TCMD24\TCC.EXE??? Support 3
vefatica Embedded perl and stdout? Support 9
jbanaszczyk Non ActiveState Python/Perl Support 4
R How to? use @everything perl regex Support 2
vefatica TPIPE's /perl option? Support 1
mikea Perl and tcc (redux) Support 7
mikea How to? TCC 15: popup windows; launching Perl scripts Support 10
M Missing PERL command-line arguments Support 1
David McClelland Perl/Tk problem with TCC (13&14) Support 3
D Documentation @PERL Support 6
epement Strawberry Perl batch file errors Support 15
David McClelland Invoking TCC FROM Perl 5.12 Support 3
M @Perl on 64bit W7 Support 7
L redirection to/by perl acts bizarrely Support 9
B Perl not working Support 8
B @PERL[expression] definition? Support 2
J How does tcc search for perl*.dll Support 1
H TTC Equivalent to Perl `One-Liner' Support 3
vefatica 9.02.156 and Perl Support 4
J @PERL and ^C Support 4
A How to? TEE - duplicate output to STDERR Support 3
FreezerBurnt ANSI Prompt messes up list output. Support 39
Ó Recent git output not shown on TCC Support 1
Peter Murschall TEE cannot handle Unicode output Support 2
C TEE command appending null characters to output Support 6
Jesse Heines webform output different in ver. 26 than ver. 25 Support 2
vefatica Piping the output of a DO loop. Support 4
vefatica TCMD output invisible on Win10 Support 22
B How can TCC make an output as a part of command string Support 2
Enigma Take Command 23 duplicates output Support 0
Joe Caverly Works with CMD.EXE, no output with TCC.EXE Support 7
S Output from debugger Support 4
M TCC incorrect dir output since Windows 1803 Support 6
A WAD Output redirection to IF block fails with "unbalanced brackets" Support 7
P Scrollable colored output Support 3
scottb How to? ipconfig output in current window Support 4
David McClelland TEE command puts it's output file in c:\ Support 4
vefatica How to? TPIPE ... see output right away? Support 4
T Fixed Unnecessary debug output Support 3
JohnQSmith Weird DIR output (missing lines) Support 1
J WAD Output redirection in tcexit looses data Support 31
vefatica Console output slower that before Support 8
Mordachai How to capture all console output from a TCMD session? Support 4
C Output continues after Ctrl-Break Support 8
Steve Pitts WAD Strange output from DEL of a non-existent directory Support 7
I v16 - cls corrupts output stream Support 7
D Fixed Minor problem: output not alligned in the tree command Support 1
vefatica WAD IDE, output window to foreground Support 3
R WAD Strange output from "memory" command Support 1

Similar threads