Problem listing repository files using DIR http(s)://...


Nov 9, 2016
Hi all.

I'm writing BTMs to download new versions of specific software automatically by reading the repository content directly, then feeding the latest release to WGET.
If target is a real FTP back-end (URI = FTP or FTPS:), then no problem. I can do the following and easily parse the result :
DIR /B*core3sdsv5i64.exe



Works a treat.

But if when the URI is HTTP or HTTPS, then I get nothing. Regardless whether the URL contains only dirs or dirs + files :

Directory of*

1 01 1601 0.00 0
0 bytes in 1 file and 0 dirs

Total for:*
0 bytes in 1 file and 0 dirs

The same URL entered in my browser gives me a list of almost 1000 lines.

So for now I do TYPE <url>, which downloads the page's HTML code, which I then have to comb through for the latest release.
Pain in the ass!

I've tried with exotic variations such as "ftp://...:80" and "https://...:21" but found no valid work-around.

Isn't there a way to get the same result with DIR /B http(s)://... as with DIR /B ftp(s)://... ?
I hope so.

Last edited:


Nov 9, 2016
@Joe :

Of course I know I can achieve my goal in Powershell or some other scripting environment, but I like TCC because it's no-nosense and versatile.
Besides, this is a JPsoft forum. It seems misplaced to suggest using other software as an answer to my question.

May 20, 2008
Syracuse, NY, USA
Whatever http(s) shows you, it's definitely not a directory. It's just text displayed however the page's author wanted it displayed.

That said, TCC can help you comb through the page. For example,
COPY http://site/webpage
TPIPE /input=webpage /simple=16

That will remove the HTML tags. TPIPE has many more features that will allow you to extract and manipulate data from a file.
Jun 2, 2008
If I open your link in a browser, I get a 404 error because of the asterisk. If I remove the asterisk, I get the list of files.
Aug 23, 2010
Keep in mind that "wget -O filename -- URL" literally equals "wget -O - -- URL > filename", which in turn defeats the most useful feature of wget - server timestamping.
Similar threads
Thread starter Title Forum Replies Date
Dick Johnson Weird Color Problem Support 8 Problem with 27.15 Support 2
M Problem with VSDevCmd.bat in VS 16.7.3 Support 0
R Problem with @INT[ value] in V26 Support 9
M Selecting test "off by one" problem in Take command Support 4
Alpengreis UTF-8 problem in TCC related to Python Support 7
K_Meinhard Small problem in german IDE 26 Support 3
B Problem with color in nested shells Support 1
Joe Caverly Problem creating and switching to a DESKTOP Support 9
vefatica Another popup problem Support 10
Alpengreis ffind dialog (/W) problem Support 4
Alpengreis [TCMD v25.00.24] Small space problem with the DE translation in Prefs-GUI Support 1
Alpengreis [TCMD v25.00.24] Problem with copy and paste and the # char via mouse in TCC Support 6
A Problem with functions @int @decimal and identifying Powershell as a shell. Support 12
B IF command problem in tcexit.btm Support 9 Problem at Startup of TCC Support 3
P Problem with SFTP copies Support 7
P Problem with FTP copies Support 10
Jay Sage Problem with Context Menu Copy+Paste+Run Key Assignment Support 7
R Problem with %_do_loop in nested do loops Support 2 New Problem with later Windows 10 Support 10
Peter Murschall A little problem with LEAVE and COMMENT Support 5
M Handling of %~I problem Support 4
WinLanEm FOR problem Support 18
K Problem With SCRPUT /u Support 3
vefatica What's TCMD's problem with ^e[0m? Support 13
Peter Murschall IDE: RTL with non-English resources-problem is back in Build 28 Support 4
rps Regex problem: \xnn not recognized as a hex character Support 0
rps PRIORITY LOW problem Support 1
old coot Regex problem: \xnn not recognized as a hex character Support 12
vefatica Another problem with build 22. Support 3
Alpengreis [23.x] Download-Problem Support 2
S Problem with " Support 3
C Problem navigating forums Support 11
Joe Caverly Problem with TEE in v22 Support 2
Alpengreis Problem with thousands delimiter and colors Support 17
M Take Command 18, migrating to another machine, license problem. Support 1
B TCC 21.01.50 Problem with ALIAS /r and SET /r Support 2
rps How to? @search problem Support 2
WinLanEm @SELECT problem Support 6
T Fixed Problem with use of Batch parameters in the IDE Support 1
Oz Solomon Problem with "list" Support 14
S V21.24 theme problem Support 2
Alpengreis Problem if command prompt is not legacy Support 4
Alpengreis TCMD.INI: The "super hidden" problem ... Support 6
G Odd problem - screen brightness Support 4
rps V20 In-process pipes problem Support 8
Alpengreis Again theme problem [v20.0.21]? Support 11
WinLanEm INPUT problem Support 1
Craig Fitzgerald problem with executable extensons with TCC version 19.10.51 x64 Support 3

Similar threads