Problem with INS key flag in the debugger status bar

May 23, 2010
60
1
Seattle
Sometimes, the INS mode flag in the edit/debug status bar indicates the opposite of reality.

In TCC, make sure INS mode is off.
Bring up a new edit/debug window.
The status bar in the edit/debug window indicates that the INS mode is off; but typing (and the cursor) indicate that INS mode is on.​
While in the edit/debug window, press the Insert key.
The status bar in the edit/debug window indicates that the INS mode is on; but typing (and the cursor) indicate that INS mode is off.​
Go back to the TCC window. At this point, one of two things can happen. It seems they happen alternately.
Scenario 1:​
Just by jumping back to the TCC window, the INS mode flag in the edit/debug window is turned off.​
Go back to the edit/debug window. Try typing. The INS mode flag is still incorrect.​
Scenario 2:​
Jumping back to the TCC window does not cause the INS mode flag in the edit/debug window to be turned off.​
In the TCC window, press the Insert key to turn INS mode on. This will cause the INS mode flag in the edit/debug window to turn off.​
Go back to the edit/debug window. You will find that typing now agrees with the INS mode flag in the status bar.​

TCC v. 28.01.14 x64
 
May 20, 2008
11,810
118
Syracuse, NY, USA
Hmmm! I can't test that one. Even though I have everything checked, Insert/Overstrike, CapsLock, and ScrollLock don't show up in my status bar.

1635641473187.png
 
May 20, 2008
11,810
118
Syracuse, NY, USA
My post was out of line. My CapsLock key is disabled and I hadn't pressed ScrollLock (and I was expecting to see something regardless of the status ... DOH!).
 

Similar threads