Problems with shortcuts

#1
My arguments don't seem to be retained when making shortcuts. After the
shortcut is created, I can't even add the @file.ini using right-click /
properties.

I want to have two different icons which start using two different INI
files.

How do I make a shortcut with a specified INI file?

TCC 11.00.50 Windows Vista [Version 6.0.6002]
TCC Build 50 Windows Vista Build 6002 Service Pack 2

C:\Users\Cookie\Desktop>shortcut "C:\Program Files\JPSoft\TCMD11\TCMD.EXE"
"@C:\Users\Cookie\AppData\Lo
cal\JPSoft\TCMD11.INI" D:\ "Take command version 11.00.50" "11.00.50 Take
Command.lnk" 1

C:\Users\Cookie\Desktop>shortcut "11.00.50 Take Command.lnk"
Command=C:\Program Files\JPSoft\TCMD11\tcmd.exe
ArgumentsDirectory=D:\
Description=Take command version 11.00.50
Link=11.00.50 Take Command.lnk
IconOffset=0
Mode=1
Hotkey
--
Jim Cook
2010 Sundays: 4/4, 6/6, 8/8, 10/10, 12/12 and 5/9, 9/5, 7/11, 11/7.
Next year they're Monday.
 

rconn

Administrator
Staff member
May 14, 2008
10,532
94
#2
> My arguments don't seem to be retained when making shortcuts. After the
> shortcut is created, I can't even add the @file.ini using right-click /
> properties.
>
> I want to have two different icons which start using two different INI
> files.
>
> How do I make a shortcut with a specified INI file?
>
> TCC 11.00.50 Windows Vista [Version 6.0.6002]
> TCC Build 50 Windows Vista Build 6002 Service Pack 2
>
> C:\Users\Cookie\Desktop>shortcut "C:\Program
> Files\JPSoft\TCMD11\TCMD.EXE"
> "@C:\Users\Cookie\AppData\Lo
> cal\JPSoft\TCMD11.INI" D:\ "Take command version 11.00.50" "11.00.50
> Take Command.lnk" 1
Try prefixing the @ with a / -- there's an undocumented Windows "feature"
that deletes shortcut arguments beginning with an @.

Rex Conn
JP Software
 
Jul 1, 2008
81
0
71
Montreal
#3
Try prefixing the @ with a / -- there's an undocumented Windows "feature"
that deletes shortcut arguments beginning with an @.
As far as I can tell, the argument is not deleted, it's just not displayed, either by the TCC shortcut command or by right-clicking on the shortcut and selecting "properties". Presumably the Windows "feature" hides it from the shortcut command. However, opening the .lnk file with a hex editor, you can see the @c:\foo\tcmd.ini argument is there. To see if it works, I copied an existing tcc shortcut and my tcmd.ini to c:\foo. I changed a couple of colour settings in tcmd.ini and added @c:\foo\tcmd.ini to the shortcut command line. It worked as expected, my colours were off.

11.0.50 under WinXP SP3
--
Peter