1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Question on File completion

Discussion in 'TCC/LE Support' started by holla, Nov 18, 2008.

  1. holla

    Joined:
    Nov 13, 2008
    Messages:
    17
    Likes Received:
    0
    I have a file called 2do.txt.
    If I type 2 at the command prompt and press tab, cmd.exe expands the filename and completes it.
    Is there any setting in TCC by which this can be achieved.
    I know I can get TCC to expand the filename(non-executable) if I prefix it with a space.
    I tried with FILECOMPLETION=:file
    and FILECOMPLETION=*:file
    settings. No Luck.
     
  2. Charles Dye

    Charles Dye Super Moderator
    Staff Member

    Joined:
    May 20, 2008
    Messages:
    3,311
    Likes Received:
    39
    At the beginning of a command line, TCC will only expand executables and subdirectory names. You can override this restriction, as you've noted, by typing a space: after the space, you're no longer at the start of the command line.

    I don't know of any way to make TCC complete all file types at the start of a command line. But if you're only interested in certain specific file types, you can make those types 'executable' by setting environment variables. (TCSTART.BTM is a good place for this kind of thing.)

    Code:
    set .txt=notepad.exe
    set .doc=winword.exe
    
    Substitute the filenames (and pathnames, if needed) of your preferred applications. See HELP EXEEXT for more info.
     
  3. Charles Dye

    Charles Dye Super Moderator
    Staff Member

    Joined:
    May 20, 2008
    Messages:
    3,311
    Likes Received:
    39
    It turns out to be pretty trivial:

    Code:
    set .*=start /pgm
    
     
    jase439 likes this.
  4. holla

    Joined:
    Nov 13, 2008
    Messages:
    17
    Likes Received:
    0
    Charles,

    Wow!
    Thank you,

    You are a legend.
    I have spent atleast 45 minutes trying to figure this out.

    --
    Holla.
     

Share This Page