Recent git output not shown on TCC

Feb 11, 2020
I'm not too happy with this post because I haven't been able to pin the problem as I would, but let's try and maybe get some ideas here.
Two things have happened recently, as far as I know:
* Git has been updated to I've found in my system some older version,, not showing the problem.
* Windows 10 has installed an update recently (10.0.18363 build 18363)

TCC's ver shows TCC 19.10.54 x64 Windows 10 [Version 6.3.18363]

Some of git commands present colored output. I somehow thought of that and passed --no-color (to disable that). But then, no output is shown! The real problem is that the default-colored output is printed in the background color, hence not visible. If we mark some text we can see it's there:


Once this happens, I don't even see the non-colored prompt until I run color white on black.

It happens only in TCC. Plain CMD doesn't show the problem, and neither does a detached window:

I've tried enabling and disabling the Options > Windows > Ansi, without any effect.

So, this is not exactly a git's problem nor a TCC one, but some interaction between them. Any idea besides updating TCC (and the corresponding license?)

Similar threads