Redirect bug?

Jun 24, 2008
223
0
Siegen, Germany
New one. Tried this:

> `"àsdf%23%39.pdf"`

got this:

TCC: (Sys) The system cannot find the file specified.
""

However, this worked:

> adsfas
ren adsfas `"àsdf%23%39.pdf"`

as:

E:\temp\down\adsfas -> E:\temp\down\àsdf%23%39.pdf
1 file renamed
 

rconn

Administrator
Staff member
May 14, 2008
12,364
150
This isn't a bug, it's the way the TCC parser works. It could be changed, but there would be a significant amount of parser rewriting involved (and an as-yet-unknown number of new compatibility issues that would arise).

Redirection occurs before back quotes are processed and removed. (Back quotes are removed after the command name and type (internal or external) is parsed and just before control is passed to the command.) So TCC is looking for the output file name for the redirection, and scans everything up to the first invalid filename character (which in this case is immediate, as the first character is the backquote). So you wind up with an empty filename, and TCC complains.

I'll look and see if it's possible to add a simple hack to check to see if a redirected filename begins with a ` and strip it then.
 
Jun 24, 2008
223
0
Siegen, Germany
I'll look and see if it's possible to add a simple hack to check to see if a redirected filename begins with a ` and strip it then.

That's good news!

I'll look and see if it's possible to add a simple hack to check to see if a redirected filename begins with a ` and strip it then.

Escaping (I think you meant ^?) will not work (my findings...) as soon there's a space character in the file name, and, to quote I would have to find all the special characters in my string, where when using `s I only would have to "embrace" it (not a big deal though...).
 
Similar threads
Thread starter Title Forum Replies Date
B How to? redirect a bunch of loop Support 4
JohnQSmith WAD DO and escaped redirect characters Support 6
J Can you redirect output to printer device with echo? Support 1
E Redirect output from "start"-ed console Support 5
D Start program without waiting and redirect output Support 6
C redirect with TCMD 8.02 Support 4
Dick Johnson v28 Cosmetic Bug Support 0
Jay Sage WAD Possible Bug With OPTION Command With @FILE Support 5
R strange bug? Support 7
Jay Sage Bug With Flow Control and/or Command Grouping Support 2
M Server 2019 Bug with @execstr? Support 14
R bug _ypixels in BDEBUGGER Support 6
E Fixed Bug with DIR /Z displaying descriptions Support 8
E Text copy bug Support 1
x13 SETARRAY /Z bug Support 6
Gamegod ffind bug with chinese Support 2
Dick Johnson cdd - is this a bug or a feature? Support 7
P "Set" command behavior - a bug? Support 3
nikbackm TCC 20 variable expansion bug Support 6
gentzel Bug launching external commands in 20.11.43 Support 11
R Is this a bug in SETARRAY? Support 2
M Windows Installer bug? Support 4
vefatica @SCRIPT bug persists Support 4
M Little bug, big consequences .. Support 6
fishman@panix.com Once again the Can't Install bug bites... Support 2
gentzel Fixed dirs +n bug in 20.0.12 x64 Support 2
M Bug in Windows 10, when adding symbol to task bar Support 6
Alpengreis [Bug?] View (V) Prefs Error (TC 18.00.27 x64) Support 4
D WAD Minor Post Installation Bug in V18 Support 1
I Possible Bug: History /n Returns Nothing Support 3
samintz WAD Weird REN bug Support 6
Jay Sage WAD Possible Bug in Batch Parameters Support 7
G Bug? TCC 16.03.55 Console Palette Support 4
S Return of FTP copy bug in 16.02.48 Support 12
S XenForo bug Support 3
D TCMD16 Delete Toolbar Button bug Support 7
keithg1964 WAD 16.0027 Alias /rz bug Support 8
rfaquino WAD Apparently a bug when expanding environment variable %ProgramFiles(x86) Support 2
T Documentation @LINE[CON,n] @LINES[CON] not documented (bug?) Support 4
H TIMER bug Support 4
G Fixed @REREPLACE bug Support 15
G WAD PDIR @IF bug, @WORD bug Support 8
T Bug in TCMD but not in TCC Support 8
M WAD A complaint regarding a very irritating TCC installation behavior... (Bug?) Support 4
nickles Renaming bug? Support 9
nickles UrlDecode() bug? Support 3
P WAD Bug in TC v 13.03 build 39 x64 Support 1
S Debug feature bug? Support 17
Roedy CDD /S bug Support 3
J TCCLE 12.11 dirhistory bug Support 1

Similar threads