1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Rexx output redirection seems to be broken

Discussion in 'Support' started by Daniel Wee, Jul 23, 2009.

  1. Daniel Wee

    Joined:
    Jul 23, 2009
    Messages:
    3
    Likes Received:
    0
    I just purchased TCC 10 and seem to have run into a problem. My system info is as follows:-

    TCC 10.00.71 Windows XP [Version 5.1.2600]
    TCC Build 71 Windows XP Build 2600 SP3

    I am using Object Rexx Version 4.0.0 (RC2).

    My problem is that whereas using 4NT9 I could run a command such as:-

    rexxcps > test.1

    and have the output redirected to the file test.1, in 4NT10 this no longer works. Executing the same command in 4NT10 will send all the output to screen and create an empty file called test.1 with 0 length.

    I have both versions 9 and 10 on my system so I can launch both 4NT9 and 4NT10 and I get this problem. This seems to relate to the Rexx installation because some of the other files seem to have their output redirected correctly. Can you let me know what I am doing wrong here?

    Daniel
     
  2. ebbe

    Joined:
    Jun 2, 2008
    Messages:
    31
    Likes Received:
    0
    Hmm, just for the fun of it, I downloaded Object Rexx, installed it and tried to run the same command - and it works as expected around here.

    I have the same version of TCMD/TCC and rexx -v gives this result:

    Open Object Rexx Version 4.0.0
    Build date: Jul 13 2009
    Addressing Mode: 32

    Copyright (c) IBM Corporation 1995, 2004.
    Copyright (c) RexxLA 2005-2009.
    All Rights Reserved.

    FOLLOW-UP:

    My first test was performed with the TCC option 'REXX Scripting' turned off. When I turn that option on, it does indeed behave as you observed. And no, this is not because it redirects to standard error. None of the redirection commands (>, >& or >&>) work, when 'REXX Scripting' is turned on.

    Ebbe
     
  3. Daniel Wee

    Joined:
    Jul 23, 2009
    Messages:
    3
    Likes Received:
    0
    Thanks ebbe, for taking the time to verify the problem exists. Am I to understand that with Rexx scripting turned off, you don't have the problem? I am not sure what the Rexx scripting option does or what I lose by turning it off. I hope JPSoft can look into this and fix it soon.

    Daniel
     
  4. ebbe

    Joined:
    Jun 2, 2008
    Messages:
    31
    Likes Received:
    0
    Correct.

    *.rex files are not recognized as executables when 'REXX scripting' is turned off, i.e. when you type part of the name, the tab key won't expand it to the full name and you need to add the extension (.rex) for the command to run. An example:

    [REXX Scriting off]

    rexxcps
    TCC: Unknown command "rexxcps"

    [REXX Scriting on]

    rexxcps
    ----- REXXCPS 2.1 -- Measuring REXX clauses/second -----
    REXX version is: REXX-ooRexx_4.0.0(MT) 6.03 13 Jul 2009
    System is: WindowsNT
    Averaging: 100 measures of 30 iterations

    Total (full DO): 0.01422 secs (average of 100 measures of 30 iterations)
    Time for one iteration (1000 clauses) was: 0.000474 seconds

    Performance: 2109705 REXX clauses per second

    Ebbe
     
  5. Daniel Wee

    Joined:
    Jul 23, 2009
    Messages:
    3
    Likes Received:
    0
    Build 72 seems to have fixed this issue! Thanks JPSoft - you guys are on the ball.

    Daniel
     

Share This Page