Run as Admin tab in non-elevated Take Command session?

Apr 1, 2018
3
0
Hello:

I've been experimenting with Hidden Start to try to start an elevated cmd prompt from a nonelevated Take Command session, like you can do in ConEmu. I know there other ways of doing this besides Hidden Start... Task Manager, VBS, Powershell, although I'd prefer to avoid the UAC box, which some of those methods don't accommodate. I'm trying to do this from an Admin user account.

I've tried a bunch of different configurations, but the closest I've come so far is to have the Admin window open in a detached tab. I've even tried to launch an Admin session of Take Command and try to attach a non-Admin tab to Take Command with Hidden Start. This appears to result in an Admin CMD tab, not a non-Admin CMD tab.

Is there some way to do this? Or, do all attached windows in a Take Command session have to be Admin or non-Admin depending on whether Take Command was launched as Admin or non-Admin?

Thanks,

Paul
 

Charles Dye

Super Moderator
Staff member
May 20, 2008
4,469
88
Albuquerque, NM
prospero.unm.edu
An elevated Take Command can attach a non-elevated console. The reverse is not true: if Take Command is not elevated, then it won't be able to attach to an elevated console.
 
Apr 1, 2018
3
0
How do we tell Take Command that we want a non-elevated Take Command tab attached to an elevated Take Command session?
 

rconn

Administrator
Staff member
May 14, 2008
12,367
150
You can't attach an elevated session to a non-elevated Take Command. (This is a Windows limitation, not TCMD.)

The only way TCMD could do this is to do what ConEmu does -- inject a dll into the console sessions, which (1) is a big no-no for corporate IT departments, (2) slows things down significantly, and (3) causes some antivirus / antimalware apps to object.
 
Apr 1, 2018
3
0
The same way you'd attach an elevated console: Tabs / Attach... Or right-click in the empty area to the right of your tabs, and select "Attach Tabs."

So, you're saying is to start a non-elevated console outside of Take Command and then you can attach that to the elevated Take Command console... is that correct?
 
May 20, 2008
11,432
99
Syracuse, NY, USA
You can also start TCC unelevated directly in an elevated TCMD using a toolbar button (as I did below) or from Tabs\Run, by entering your username and password. Here's a pic of an elevated TCMD and an unelevated TCC started with the "test" toolbar button.
1522983213244.png
 
May 20, 2008
11,432
99
Syracuse, NY, USA
You can also start TCC unelevated directly in an elevated TCMD using a toolbar button (as I did below) or from Tabs\Run, by entering your username and password. Here's a pic of an elevated TCMD and an unelevated TCC started with the "test" toolbar button.

There may be a problem with that, TCMD doesn't seem to save user/password for toolbar buttons. Rex, is it supposed to save those things?
 
Similar threads
Thread starter Title Forum Replies Date
M How to? Windows 7 - run TCC as admin w/o UAC intercept Support 4
vefatica What limit have I run into? Support 9
S How to? Runs start /w in invisible mode OR run program after exit of another one Support 3
Jay Sage Command Will Not Run Using Short Name of Path Support 5
Peter Murschall BDEBUGGER "Run to Cursor" - where is it ? Support 1
Jay Sage Problem with Context Menu Copy+Paste+Run Key Assignment Support 7
D What does the file "..\Everything\Run history.csv" store? Support 5
dcantor How to? Can 32-bit TCC be run on a system with 64-bit TCMD and TCC installed? Support 6
G tcedit ist not run in tc 24 file explorer Support 10
A Windows 10 This app can't run on your PC Support 2
Roedy run as administrator Support 27
rps Documentation "Copy+Paste+run" question Support 2
Peter Murschall IDE/BDEBUUGER in TCC 22 didn't run Support 7
fpefpe How to? which will run? Support 1
C How to? run a BTM in elevated, inv tcc tab window Support 9
M How to? Run the control panel from a TCC session... Support 2
M How to? Run TCC from Windows Install DVD... Support 2
B Batch file won't run if there is already an instance of TC 17 running Support 9
P MS VS2013 vsdevcmd.bat fails to run with tcmd 17 x64 Support 10
redwdc btm won't run in ver. 17 but works in ver. 16 Support 11
C How to? run a batch file in administrator mode while debugging in take command software Support 1
Joe Caverly How to? Run DOS .exe's the same way Wine does... Support 3
tmaynard How to? Any way to run a command in a new tab at startup? Support 18
vefatica Why isn't TCSTART.BTM run? Support 8
M Installed but can't run Take Command 16.0 Support 5
D Run all .CMD batch files with CMD.EXE Support 16
Joe Caverly Run As Administrator in TCMD16 Support 3
F Sending "Y" to chkdsk to run on C at next reboot Support 25
T tcc /c "[...]" fails when run from third party terminal Support 11
B Select and run lines from Command Input panel? Support 1
Jay Sage Specified INI File Refuses to Run Support 3
A How to? Run a TCC command from external program Support 2
C How to? create a JPSoft BTM menu to run custom custom batch files Support 2
vefatica Coruption after which BTMs won't run Support 7
M How to? Run a command (alias, actually) on a "timed" basis... Support 13
Joe Caverly Copy Paste Run Support 12
S Fixed TCC.EXE 13.03.47 won't run Support 4
Stefano Piccardi run as limited user Support 2
E TCC requires elevation to run Support 2
Jay Sage How to Run Non-Elevated From Elevated TCC Support 1
L How can I run tcmd in terminal window only? Support 13
S Run as Administrator question Support 3
Joe Caverly TCMD12 Beta Expired, TCMD11 will not run Support 7
p.f.moore Run as administrator from TCC Support 2
vefatica Help from IDE fails after a non-debug run Support 5
B TCC doesn't run using another user Support 2
A How to Run the 4NT 8.02 .INI Key Version Support 3
K double click to run btm? Support 2
D TCC won't run telnet on Windows 7 RC1 Support 5
D Can I use TC to run Cygwin? Support 4

Similar threads