Sansa Clip+ Directory Listing

  • This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
#1
I use the Sansa Clip+ MP3 players for my music and would like to be able to get a directory (file) listing off of them, but it seems that nothing except Windows Explorer (and XPlorer²) can access it in a manner where I can see the files, but I can't generate a "list" from them. Anyone ever do this or have any suggestions ? I'm using Win7 pro x64 and TCMD 12.10.64 x64 (I generally just use TCC).

thanks…

Mr. Jiggs
 
#2
Anyone ever do this or have any suggestions ?
As a matter of fact, yes, since my youngest has that MP3 player and I managed to get my standard album copy REXX routine to work with the device.

You need to put the player into MSC mode rather than using the Default or MTP mode. You do this on the player using Settings > System Settings > USB Mode
 
#3
As a matter of fact, yes, since my youngest has that MP3 player and I managed to get my standard album copy REXX routine to work with the device.

You need to put the player into MSC mode rather than using the Default or MTP mode. You do this on the player using Settings > System Settings > USB Mode
Thanks Steve… Forgot all about switching the mode !!
 
#4
As a matter of fact, yes, since my youngest has that MP3 player and I managed to get my standard album copy REXX routine to work with the device.

You need to put the player into MSC mode rather than using the Default or MTP mode. You do this on the player using Settings > System Settings > USB Mode
That worked for accessing the sdhc card I put in it, but the Music folder in the built in area lists 0 files ? (There's actually hundreds)

Any ideas ?
 
#6
Not something that I noticed whilst setting things up for my daughter, and I can't check because hers is dead (damaged in a fit of pique {sigh}). Does Windows see files in that folder when in MSC mode?? (Apologies for the A-level egg sucking, but) Have you tried a

DIR /a: /s

such that all files are listed??
Everything works as expected (hoped) when accessing the removable storage, but the built in storage only reports the directory structure, no files. On the way in this morning I remembered that I didn't try my own VB app for reading it, so I'll give that a go tonight.

…thanks