Saving out Command Input window

  • This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
Oct 11, 2011
5
0
#1
In version 11, I had Take Command set up to save out the Command Input window contents, and then start up again with those contents restored to the Command Input window. This doesn't seem to be working in version 13 (or else I just haven't set it up correctly). I have a filename specified in the CommandInputFile="C:\Personal\TCCCommandInput.txt" in the ini file. I can actually copy a command in that file, and when Take Command starts up, that command will appear in the Command Input window. But when I exit out of Take Command, that file will have it's contents deleted, and when I start up Take Command again, there will be nothing in the Command Input window. Am I doing something wrong?
 

Charles Dye

Super Moderator
Staff member
May 20, 2008
3,383
39
Albuquerque, NM
prospero.unm.edu
#2
It works for me.

However, I do notice that when the text file is loaded, the BOM at the start winds up in the command input window (it appears as a little square.) When Take Command closes, the buffer is saved, including the BOM, but a new BOM is prepended, so there are now two BOMs at the front. Exit and restart, and I have three BOMs....
 
Oct 11, 2011
5
0
#3
Okay, it appears to now be working. I think it had to do with the way I initially had the commands formatted in the txt file to start with.
 

rconn

Administrator
Staff member
May 14, 2008
10,100
85
#4
However, I do notice that when the text file is loaded, the BOM at the start winds up in the command input window (it appears as a little square.) When Take Command closes, the buffer is saved, including the BOM, but a new BOM is prepended, so there are now two BOMs at the front. Exit and restart, and I have three BOMs....
Fixed in build 27.