WAD /= size ranges not set correctly

  • This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
May 20, 2009
216
0
53
ITALY
#1
I want to see all files that are at least 10 bytes long.
I type dir /=.
It appears the box where I can specify criteria.
I click on the Ranges button.
If I type 10 in the Minimum field and leave empty the Maximum field, it suggests "/[s10,0]".
This is a bug, since it means the opposite, files that are at most 10 bytes long.
Instead, it should suggest "/[s10]", I believe.
And, if I leave the Minimum field blank, it does not suggest anything.


Regards

Rodolfo Giovanninetti
 
#3
If you enter a minimum you need to enter a maximum as well. The "Result" line is the current state of the range you're building, not a "suggestion", and definitely not the final desired result.
Admittedly, I do not use the dialog boxes to build commands. However, if I did, for ranges I'd like to be able to specify just one of minimum and maximum, leaving the other end unlimited, just as one can do when the range option is manually built. IMHO the dialog default for the as yet unspecified limit ought to be the same it is when that limit is unspecified in an explicit range. However, it is definitely not worth losing even a minute's sleep over.
 

rconn

Administrator
Staff member
May 14, 2008
10,100
85
#4
Admittedly, I do not use the dialog boxes to build commands. However, if I did, for ranges I'd like to be able to specify just one of minimum and maximum, leaving the other end unlimited, just as one can do when the range option is manually built. IMHO the dialog default for the as yet unspecified limit ought to be the same it is when that limit is unspecified in an explicit range.
You do realize that whenever I see something that starts with "I do not use ... however, if I did ...", it goes immediately into the circular file? ;)

In this case, it's irrelevant, because for size ranges you always have to specify the minimum and maximum, whether you do it on the command line or in the command dialog. There are no defaults. (And it's impractical to even try, since different file systems have different maximum sizes, and at the point the command dialog is being executed TCC has no idea what file system will be used.)
 
May 20, 2009
216
0
53
ITALY
#5
...
In this case, it's irrelevant, because for size ranges you always have to specify the minimum and maximum, whether you do it on the command line or in the command dialog. There are no defaults. (And it's impractical to even try, since different file systems have different maximum sizes, and at the point the command dialog is being executed TCC has no idea what file system will be used.)
In the help it says: "Size ranges select files whose size is between the inclusive limits specified. The second parameter of a size range is optional. If you use a single parameter, you will select all files of the specified size or larger. ...". And one of the examples is "/[s1M] 2**20 bytes or larger".
I tried on fat and on ntfs and it seems to work, for example with TakeCommand directory itself:

[C:\a]*dir /[s1000000] /O:s

Volume in drive C is unlabeled Serial number is 4717:4a93
Directory of C:\a\*

12/08/2013 09:37 1.056.440 ipworksssl9.dll
12/08/2013 17:38 1.061.048 ipworks9.dll
06/12/2013 05:30 1.356.896 takecmd.dll
06/12/2013 05:30 2.280.544 v.exe
08/01/2013 03:54 2.315.072 IsLicense50.dll
06/12/2013 05:29 3.627.411 tcmd.chm
06/12/2013 05:30 4.381.280 tcmd.exe
06/12/2013 05:30 4.530.272 ide.exe
22/08/2013 16:01 9.004.648 textpipeengine.dll

So, it seems to me that it work, and so it should do the same also with "/=".
Otherwise, please consider it as an improvement for a future release.

I do not understand what You mean when You say
...
There are no defaults. (And it's impractical to even try, since different file systems have different maximum sizes, and at the point the command dialog is being executed TCC has no idea what file system will be used.)
If I DO NOT specify a maximum, my idea is that the command must consider any file that is at least long as the minimum size, up to ANY value.
So, the test should be something like "if filesize ge minimum".

Thank You and regards

Rodolfo Giovanninetti