1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Smooth scrolling in a TCC window

Discussion in 'Support' started by Steve Fabian, Oct 27, 2011.

  1. Steve Fabian

    Joined:
    May 20, 2008
    Messages:
    3,520
    Likes Received:
    4
    I use stand-alone TCC sessions in WinXP SP3 (no TCMD tabs). They use smooth scrolling. I did not find any entry in the OPTION dialogs to disable it. Searching through my .INI files, no directive name including "smooth" was found, and the only directive name containing "scroll" was for V6. How can I disable smooth scrolling?
    --
    Steve
     
  2. vefatica

    Joined:
    May 20, 2008
    Messages:
    8,129
    Likes Received:
    33
    On Thu, 27 Oct 2011 12:31:50 -0400, Steve Fabian <> wrote:

    |I use stand-alone TCC sessions in WinXP SP3 (no TCMD tabs). They use smooth scrolling. I did not find any entry in the OPTION dialogs to disable it. Searching through my .INI files, no directive name including "smooth" was found, and the only directive name containing "scroll" was for V6. How can I disable smooth scrolling?

    I have not seen nor heard of anything but the default scrolling in a console.
    Googling "smooth scrolling" "windows console" turned up nothing interesting. The
    only place I can think of to look would be
    MyComputer\Properties\Advanced\Performance (but I'm pretty sure there's nothing
    apropos there).
     
  3. samintz

    samintz Scott Mintz

    Joined:
    May 20, 2008
    Messages:
    1,203
    Likes Received:
    11
    Does it happen in a CMD window or only in TCC?

    -Scott

    Steve Fabian <> wrote on 10/27/2011 12:31:49 PM:


     
  4. rconn

    rconn Administrator
    Staff Member

    Joined:
    May 14, 2008
    Messages:
    10,091
    Likes Received:
    85
    It is not a TCC option. The scrolling in a TCC window is controlled by the
    Windows console manager.

    You probably have a screen manager or display driver option that you set and
    then forgot.
     
  5. Steve Fabian

    Joined:
    May 20, 2008
    Messages:
    3,520
    Likes Received:
    4
    From: samintz
    | Does it happen in a CMD window or only in TCC?

    Apparently yes, judging by the screen fill rate of a DIR/B/S after a CLS. Starting at top it is very rapid, after which (when the screen needs to be scrolled) it slows down considerably. Scroll rate of CMD and TCC is appears not to be significantly different (not measured...).

    Vince:
    I did not find any registry keys resembling the one you mentioned.

    Rex:
    I went back to "Display Properties". Searched everywhere, there is no control for smooth scrolling.

    I am at a loss!
    --
    Steve
     
  6. vefatica

    Joined:
    May 20, 2008
    Messages:
    8,129
    Likes Received:
    33
    On Thu, 27 Oct 2011 13:44:56 -0400, Steve Fabian <> wrote:

    |Vince:
    |I did not find any registry keys resembling the one you mentioned.

    Not a registry key ... right-click MyComputer ...
    Properties\Advanced\Performance.

    Are you using a magnifier or any other gadget that might change the way consoles
    work?
     
  7. TEA-Time

    Joined:
    Jun 2, 2008
    Messages:
    282
    Likes Received:
    1
    There's one in Control Panel->Internet Options on the Advanced tab... I'm pretty sure it at least also affects Windows Explorer.

    I've also seen differences in display adapter (like nVidia vs ATI) affect console window scrolling speed. I believe ATIs were the slower.
     
  8. Steve Fabian

    Joined:
    May 20, 2008
    Messages:
    3,520
    Likes Received:
    4
    From: vefatica
    || I did not find any registry keys resembling the one you mentioned.
    |
    | Not a registry key ... right-click MyComputer ...
    | Properties\Advanced\Performance.

    Thanks, found it, system set for "maximum performance", nothing set to smooth scroll.

    | Are you using a magnifier or any other gadget that might change the way consoles
    | work?

    Nothing.
    --
    Steve
     
  9. Steve Fabian

    Joined:
    May 20, 2008
    Messages:
    3,520
    Likes Received:
    4
    From: TEA-Time
    | There's one in Control Panel->Internet Options on the Advanced tab...
    | I'm pretty sure it at least also affects Windows Explorer.

    I never intentionally start IE. I searched the IE Options dialog, no smooth scrolling marked.

    | I've also seen differences in display adapter (like nVidia vs ATI)
    | affect console window scrolling speed. I believe ATIs were the
    | slower.

    That may be my issue, though it also affects my Dell Laptop (an old one).

    Thanks everyone, seems I just have to live with slower display...
    --
    Steve
     
  10. samintz

    samintz Scott Mintz

    Joined:
    May 20, 2008
    Messages:
    1,203
    Likes Received:
    11
    Are you absolutely certain that there isn't a setting under the advanced
    section for your display adapter's properties?

    -Scott




    From: samintz
    | Does it happen in a CMD window or only in TCC?

    Apparently yes, judging by the screen fill rate of a DIR/B/S after a CLS.
    Starting at top it is very rapid, after which (when the screen needs to be
    scrolled) it slows down considerably. Scroll rate of CMD and TCC is
    appears not to be significantly different (not measured...).

    Vince:
    I did not find any registry keys resembling the one you mentioned.

    Rex:
    I went back to "Display Properties". Searched everywhere, there is no
    control for smooth scrolling.

    I am at a loss!
    --
    Steve
     

Share This Page