'start tcmd.exe' actually starts tcc.exe

  • This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
#1
*start "C:\Program Files\JPSoft\TCMD16x64\tcmd.exe" actually starts tcc.exe (the real command is part of a batch file and uses a '/runas …' option, I execute it in a tcc tab within a tcmd window).

I can work around (launch tcmd.exe (without 'start') from the new tcc window), but I wonder whether the behavior is expected.

TCC 16.00.41 x64. I tested after having renamed tcmd.ini and having removed aliases ('unalias *').
 
Dec 2, 2008
209
2
Canada
#2
start's purpose is to "Start a program in another session or window", I would think TCC would be used to start "another session or window". I think you want to use the "/PGM" option on the "start" command.
 
#5
Here "start path\tcmd.exe" with neither /PGM nor an empty quoted sting in START are required for tcmd to start; likewise, "start firefox" and "start iexplore" work as shown. Is there an alias issue?
I'd have to guess that your path to TCMD.EXE doesn't contain spaces, so you can get away without quotes. If it must be quoted, there will be confusion with the "title" parameter.
 
#6
Vince, you are right. What I wrote was not wrong, but so irrelevant that it was misleading (no embedded spaces anywhere). START works exactly as HELP describes if you read all of the leading paragraphs, esp. the "Valid" and "Invalid" examples. cgunhouse suggests the first of the valid examples, Charles Dye the second. Unfortunately the OP matched the invalid example.
 
#8
Thanks for the answers.

The problem showed up in a script I use only from time to time; the quotes come from the %@quote[] function; when I last installed Take Command (the IT staff replaced my computer some time ago), I chose this time the standard "C:\Program Files" rather than a custom directory — the new space in the name triggered the quotes and the resulting unexpected behavior. I didn't remind the /pgm option.