Strange... lpksetup

Nov 3, 2012
25
0
#1
Hi,

i'm having a problem with tcmd/tccle. Under Windows 8.1 x64 i create a .BTM file with the BATCOMP function included in tcmd. This is my batch:

START "" /MIN /WAIT calc.exe

Once saved the previous batch as "file.btm", i launch this command:

tcc.exe file.btm

The batch works, opening the Windows calculator.

Now, if i want to open the lpksetup.exe, located in the System32 folder, the same of calc.exe, the batch doesn't find the file. Why? How can i solve?

Thank you
 
Nov 3, 2012
25
0
#3
Hi Rex, thank you for your reply.
Right, i'm using TCC 32-bit under Windows 8.1 64-bit. Is there a solution? I need to use a unique version of TCC, fully compatible with 32 and 64-bit OS.

Thank you very much for your work!
 

rconn

Administrator
Staff member
May 14, 2008
10,426
95
#4
Not sure what you're trying to do here -- the solution is to use the 32-bit TCC in Windows x86, and the 64-bit TCC in Windows x64. They're exactly the same in syntax & functionality.

If for some reason you only want to use the 32-bit version of TCC in Windows x64, you should uncheck the "Win64 File System Redirection" option in the OPTION / Startup dialog. This will allow the 32-bit TCC to see the 64-bit directories that Windows normally hides from 32-bit apps. However, you still won't see the 64-bit Windows Registry entries, and the 32-bit TCC will run 10-20% slower than the 64-bit version.