WAD SYNC command problem

V

Vovan

Guest
Hi!

I download TCC 13 and tried to use SYNC command for backup.

I found, that if copy was interrupted in the middle (just kill tcc.exe in Task Manager) destination file remain with modification time set to "now" and next run of SYNC begins copying from destination to source destroying original file. I tried /J switch, but it didn't help.

Actually the same applies to COPY command (but wouldn't destroy original file, just skip copy).


System is Win7/32 SP1.

Thanks.
 

rconn

Administrator
Staff member
May 14, 2008
12,404
152
Not sure *why* you would do that, but ...

It's a Windows problem. SYNC (and COPY) use the Windows CopyFileEx API, and TCC doesn't have any control over what happens when you interrupt it (or any knowledge of exactly when it was interrupted).

It might be possible in TCC to detect that it was interrupted, and then unilaterally delete the last target file, though I don't know that it would be an improvement.
 
V

Vovan

Guest
Not sure *why* you would do that
I wanted test the case of failure in process of backup, for instance electricity interrupt or BSOD in Windows.

It might be possible in TCC to detect that it was interrupted
I guessed /J option serves for this purpose - "The copy progress is tracked in the destination file in case the copy fails. The copy can be restarted by specifying the same source and destination file names." What is exactly semantic of this switch?

Actually I don't need SYNC, but COPY with switches /U /W. Though it will prevent from destroy source file, but leave corrupted file in destination folder with newer creation time.

I don't know that it would be an improvement.
I would suggest implement new switch for COPY command - copy if destination file has just different time than source. It seems very easy to realize.
 
Similar threads
Thread starter Title Forum Replies Date
Alpengreis [v22.00.41] sync command flag "/X" does not work Support 22
M Sync folder/list view with command window? Support 2
CWBillow Sync Folder Tree and Command Window? Support 11
D SYNC /W copies back instead of propagating a delete Support 2
thorntonpg sync /S /F creating empty directories Support 5
Joe Caverly How to? Use SYNC with a network drive Support 4
R SYNC /T /W does not suppress "deleting" messages Support 0
krischik SYNC crashes TCC Support 6
Peter Bratton Sync Surprise Support 6
D sync navigation between Folders List panel and the Tabs console Support 11
P Sync /w won't delete in ftp folder Support 1
A Inverse of CDD /t c:\ (sync TCC currdir to Folders view)? Support 9
N Problem with Sync? Support 0
Z CMDDebug - TCC unknown command Support 2
F Edit command Support 1
rconn News Take Command / TCC / CMDebug / TCC-RT 28.02.17 Support 0
old coot LEAVE appears to affect command-line arguments Support 11
J VDESKTOP command Support 3
old coot tee command cancels colors Support 33
Dmitry L. Kobyakov How to? How to remove the record of the old version of the Take Command? Support 9
D Can alias pass parameters to for command? Support 3
samintz How to? Search for %(command) in Help? Support 1
T VIEW only works from command line Support 14
rconn News Take Command / TCC / CMDebug / TCC-RT v28 Released Support 0
T Take Command 28: Lua reports version 5.4.0 (5.4.3 expected) [SOLVED] Support 1
Jay Sage WAD Possible Bug With OPTION Command With @FILE Support 5
rconn News Take Command / TCC / CMDebug / TCC-RT 27.01.24 uploaded Support 0
J Take command does not start on Windows 10 Support 3
vefatica `Back quotes` - command line vs. batch file Support 5
Jay Sage WAD Failure of Alias Command with /Z Option Support 14
Phileosophos Is there any way to open the Take Command options dialog from the command line? Support 8
Phileosophos Command-line Editing Shortkeys That Fail Support 6
fpefpe How to? free (internal) command Support 0
rconn News Take Command / TCC / CMDebug / TCC-RT 27.01.23 uploaded Support 0
T How to? retain command history across reboot? Support 6
rconn News Take Command / TCC / CMDebug / TCC-RT v27.01 Build 22 Uploaded Support 0
Jay Sage Bug With Flow Control and/or Command Grouping Support 2
GermanDirk How to? EVENTLOG Command with simple User Rights not functional Support 4
Jay Sage Take Command Is Too Fast! Support 4
Jay Sage Comparison of IF with Command Group and IFF Support 6
D Open Windows 10 Photos app from command line Support 11
rconn News Take Command / TCC / CMDebug / TCC-RT 27.0.21 uploaded Support 0
rconn News Take Command / TCC / CMDebug / TCC-RT 27.0.20 uploaded Support 0
U Can not get/start Take Command gui Support 1
rconn News Take Command / TCC / CMDebug / TCC-RT 27.0.19 Support 0
S Increasing Font Point Size in Command Tabs Support 2
mfarah Fixed The DATE command produces the wrong error message. Support 1
vefatica Command name mix-up Support 3
FreezerBurnt "Missing SETLOCAL" when initializing Visual Studio Command Prompt. Support 9
E How to? Closing desktop created by DESKTOP command Support 10

Similar threads