System Error: A required privilege is not held by the client.

  • This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
Mar 16, 2010
4
0
#1
I bought a new computer with an i7 Quad Core chip and installed Windows 7 Ultimate on it. I am running Take Command 11 x64 Build 40.

When I enter the following command to index the c: drive

cdd /s c:

I recieve the above error message which is Windows Error 1314 followed by the filename
"c:\jpstree.idx"

Can you tell me how to correct this error. Thanks
 

dim

Dimitry Andric
May 31, 2008
203
0
Netherlands
#2
On 2010-03-17 06:47, Drew Copeland wrote:

> I bought a new computer with an i7 Quad Core chip and installed Windows 7 Ultimate on it. I am running Take Command 11 x64 Build 40.
>
> When I enter the following command to index the c: drive
>
> cdd /s c:
>
> I recieve the above error message which is Windows Error 1314 followed by the filename
> "c:\jpstree.idx"
>
> Can you tell me how to correct this error. Thanks
You are most likely not "elevated", which means you cannot write into
the root of the C: drive (or more likely, any drive). What does:

echo %_elevated

say? If it says 0, you need to start Take Command or TCC as an
administrator.

Alternatively, turn off the elevation stuff in the Control Panel, but
that should only be done if you know you need it. ;)
 

rconn

Administrator
Staff member
May 14, 2008
10,100
85
#3
> I bought a new computer with an i7 Quad Core chip and installed Windows
> 7 Ultimate on it. I am running Take Command 11 x64 Build 40.
>
> When I enter the following command to index the c: drive
>
> cdd /s c:
>
> I recieve the above error message which is Windows Error 1314 followed
> by the filename
> "c:\jpstree.idx"
Windows is blocking access to the root of the C: drive. Normally, TCC will
use the "APPDATA" value in the environment to specify the location of
JPSTREE.IDX, but that's apparently either missing or pointing to the root on
your system.

You can manually select the location of JPSTREE.IDX in OPTION / Command Line
/ Extended Directory Search / Path.

Rex Conn
JP Software
 
Mar 16, 2010
4
0
#4
Rex - I checked to see if the APPDATA value was set in the enviroment. It was set to

C:\Users\Drew A Copeland\AppData\Roaming

so I don't see why TCC would not use that path? Why would Windows would prevent access to the root of the system?

I did notice under Control Panel\System\System Protection

that protection is ON for the C:\ drive which is where the OS is stored. This apparently lets you set restore points and if I turn it off it will then not store restore points. (I am not sure about this).

Could this be the cause of this problem and why Windows is not letting me have the required privilege?

Thanks for your help.

Also I don't understand this forum very well and how to submit replies to posts etc. Are there some directions somewhere. It is a little confusing. Thanks
 

rconn

Administrator
Staff member
May 14, 2008
10,100
85
#5
> Rex - I checked to see if the APPDATA value was set in the enviroment.
> It was set to
>
> C:\Users\Drew A Copeland\AppData\Roaming
>
> so I don't see why TCC would not use that path? Why would Windows would
> prevent access to the root of the system?
TCC is actually looking for LOCALAPPDATA. If it can't find that in the
environment, it will use C:\. Windows 7 will not let you write to the root
unless your process is elevated.

But if you set the directory in OPTION, you won't have to worry about any of
this.

Rex Conn
JP Software