1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Take Command Prevents Seeing Hidden Files

Discussion in 'Support' started by Dnison Penndragon, Feb 15, 2012.

  1. Dnison Penndragon

    Joined:
    Feb 15, 2012
    Messages:
    5
    Likes Received:
    0
    I have an odd problem after upgrading TakeCommand to v13 (from v6). I set "Show Hidden Files" in the TCMD options, but the folder and list panes will not show any hidden or system files.

    Even stranger, TCMD seems to prevent any other application from seeing hidden or system files also. While TCMD is running, I can no longer see hidden files with Explorer or PowerDesk.

    If I have PowerDesk and/or Explorer open before TCMD, the file view in PowerDesk changes while TCMD loads. Explorer needs F5 to refresh, but it's the same behavior - displaying hidden files while running on their own, but not once TCMD loads. Without TCMD running, any app can see hidden files - once TCMD loads, no app can see hidden files (except "dir /ah" on the CMD or TCC command lines).

    The reverse is true also. If TCMD is running first I see no hidden files, and neither does PowerDesk or Explorer if I launch them. If I close TCMD, both PowerDesk and Explorer can then see hidden files.

    Is their some global setting I am missing? The Explorer Tools --> Folder Options --> View settings are set to "Show hidden files and folders" obviously, since Explorer and PowerDesk work fine as long as TCMD isn't running.

    The system is running Windows Server 2003 SP2.
     
  2. rconn

    rconn Administrator
    Staff Member

    Joined:
    May 14, 2008
    Messages:
    9,730
    Likes Received:
    80
    Not reproducible here. Did you restart TCMD (required) after setting or clearing "Show Hidden Files"?

    TCMD saves the current Windows shell flags and then adds some additional options (not normally supported in Explorer) for the TCMD tree & list views. When TCMD exits, it restores the saved values.

    There are three TCMD.INI settings involved here:

    ShowHiddenFiles - shows hidden files and directories
    ShowSysFiles - shows system files
    ShowSuperHidden - shows hidden OS files

    Only ShowHiddenFiles is settable from the options dialog; if you want the others you'll have to add them manually to your TCMD.INI.
     
  3. Dnison Penndragon

    Joined:
    Feb 15, 2012
    Messages:
    5
    Likes Received:
    0
    I did get it working last night after it occured to me that it was specifically system files that were not being shown. I checked the Windows value "Hide protected operating system files" and it had become set after running TCMD. That seemed strange since it had never been set before and Explorer and PowerDesk had always shown me those files. And, as I said in the OP, both still did show those files provided that TCMD wasn't running.

    I checked off that setting again, and now everything is displaying correctly. The settings in tcmd.ini are:
    ShowHiddenFiles=Yes
    ShowSysFiles=No
    ShowSuperHidden=No
    Two of the setting are set to No, but TCMD still shows all system and OS files.
     

Share This Page