Take Command stuck at 78x21

#1
I recently upgraded to a new laptop. It came with Windows 10 and has a 4K display, so this could be an issue with either change from my previous setup (Windows 7 and 1920x1080 display).

Take Command always shows its windows size as 78x21 and limits the text it will display based on that. If I resize the windows to be smaller than that TC does reduce the amount of text to fit properly, but no matter how large a window I create it is always limited to 78x21. I can fill most of my screen with a huge window and get text only in the upper left corner with the rest of the window empty.

Just to be clear, the window works normally except that text begins to wrap at column 78 and to scroll at row 21, even if there is plenty of open space to the right and below. It acts exactly like it would if the window were much smaller.

I do not have this problem if I open a console window with just TCC, it only happens with Take Command.

Can anyone tell me why this is happening and how I can fix it?

--Bob Q
 

rconn

Administrator
Staff member
May 14, 2008
10,551
97
#2
It's a Windows issue, not TCC or Take Command.

Windows will not let you create a console window larger than what will fit on the display, based on the size of the default font. Take Command runs console windows hidden and displays their contents in its tab windows. So in order to create larger console windows (and thus tab windows) you'll need to decrease the default Windows console font size.
 
#3
Thank you for the answer. I was able to get the Take Command console to work better by shrinking down the font of the default Windows console to the point where I can't actually read it.

What I don't understand is why this doesn't happen when I open a CMD console or a TCC console. I can resize a CMD console to any size up to full screen and it will still fill up normally no matter what font size I have selected. The same is true of a bare TCC console window. The only time I have this problem is when using Take Command.

Is there a zoom-type setting that would get around this issue?

--Bob Q