Take Command / TCMD/LE / TCC/LE 10.00.50 uploaded

rconn

Administrator
Staff member
May 14, 2008
10,779
97
#1
I've uploaded build 50 to the web and ftp sites.

* Take Command and TCC are slightly faster.

* Fixed a problem when changing the history/directory history/alias/
function lists from global to local in the OPTION dialog.

* Fixed a problem with TCEXIT not always being called when the
TCMD or TCC window is shut down from the system menu or the
close button. (Note that you cannot count on a lengthy TCEXIT
actually being executed in that instance, as Windows will forcibly
shut down the process within 2-3 seconds whether TCEXIT is still
executing or not.)

* Fixed a problem with background bitmaps when the filename is
enclosed in (unnecessary) double quotes.

* Take Command now clears the list view window if you select an
entry in the tree view that has no corresponding list view (for
example, "Desktop" or "Computer").
 
May 29, 2008
533
3
Groton, CT
#2
I've uploaded build 50 to the web and ftp sites.
...

Upon installation, starting this version gave me the choice window to register or proceed with the notation that the trial ends in 30 days. When I dismissed that window I got an error window



Code:
[bold]
Take Command has encountered a problem and needs to close.  We are sorry for the inconvenience.
[/bold]
If you were in the middle of something, the information you were working on might be lost.
For more information about this error, click here.
On clicking there, this appeared:
Code:
Error signature
AppName: tcmd.exe                 AppVer: 10.0.0.50   ModName: tcmd.exe
ModVer: 10.0.0.50    Offset: 0004a893
To view technical information about the error report, click here.
Clicking there results in a display of a dump.


This is repeatable.
 
May 20, 2008
457
2
#3
TCEXIT confirmed fixed on WinXP. When trying to start on Win7, it now faults and aborts. Here is some data:

Log Name: Application
Source: Windows Error Reporting
Date: 2/8/2009 10:00:17 PM
Event ID: 1001
Task Category: None
Level: Information
Keywords: Classic
User: N/A
Computer: TB-Win7
Description:
Fault bucket 1135859404, type 1
Event Name: APPCRASH
Response: Not available
Cab Id: 578228907

Problem signature:
P1: tcmd.exe
P2: 10.0.0.50
P3: 498f8728
P4: tcmd.exe
P5: 10.0.0.50
P6: 498f8728
P7: c0000005
P8: 0004a893
P9:
P10:

Analysis symbol: NULL_CLASS_PTR_DEREFERENCE_c0000005_tcmd.exe!Unknown
Rechecking for solution: 0
Report Id: 15a8d804-f65e-11dd-87e1-001c420e20ee
Report Status: 24
 
May 30, 2008
1
0
#4
Doesn't run here at all, I just get an offer to send data to Microsoft when I try to start the program:
Code:
AppName: tcmd.exe	 AppVer: 10.0.0.50	 ModName: tcmd.exe
ModVer: 10.0.0.50	 Offset: 0004a893
I have tried the internal update and downloading a new installation file. Running XP SP3.
 
#5
I've uploaded build 50 to the web and ftp sites.

* Take Command and TCC are slightly faster.

* Fixed a problem when changing the history/directory history/alias/
function lists from global to local in the OPTION dialog.

* Fixed a problem with TCEXIT not always being called when the
TCMD or TCC window is shut down from the system menu or the
close button. (Note that you cannot count on a lengthy TCEXIT
actually being executed in that instance, as Windows will forcibly
shut down the process within 2-3 seconds whether TCEXIT is still
executing or not.)

* Fixed a problem with background bitmaps when the filename is
enclosed in (unnecessary) double quotes.

* Take Command now clears the list view window if you select an
entry in the tree view that has no corresponding list view (for
example, "Desktop" or "Computer").
I installed into the same folder where I had version 9 installed (C:\JPSoft\TCMD). Got the "register" dialog, registered (successfully) and then got the MS "encountered a problem" dialog. Did an Uninstall (via Add/Remove) and Reinstall. Same result. TCMD won't start, but TCC.exe seems to be okay.

Win XPpro SP3
Mr. Jiggs
 

samintz

Scott Mintz
May 20, 2008
1,313
11
Solon, OH, USA
#7
I have not encountered any issues with build 50. However, the installer
doesn't seem to remember my previous installation folder.

-Scott

dcantor <> wrote on 02/09/2009 09:59:32 AM:


> ---Quote (Originally by Mr. Jiggs)---
> ... TCMD won't start, but TCC.exe seems to be okay.
> ---End Quote---
> I hadn't tried TCC alone earlier when I reported the crash. I tried it.
> Yes, TCC 10.00.50 runs just fine here, too. TC crashes.
>
>
>
>
 
#10
I don't have a TCMD.INI.
My TCSTART.BTM is:

@echo off
Color Bright Cyan on Black
prompt=`%=e[0;1;%@if[%@remote[%_disk] eq
1,37,32];40m%@left[3,%_cwds]%=e[0;%@if[%@remote[%_disk] eq
0,36,31];40m%@if[%@len[%_cwds] gt
26,%@InStr[3,6,%_cwds]...%@right[14,%_cwds],%@Instr[3,,%_cwds]]%=e[33;40
;1m$s`
set titleprompt=` [%_cmdproc %_4ver%.%_build%] %@lfn[%_cwd]`
ALIAS /R "C:\JPSoft\TCmd\ALIAS.FIL"
Function /r c:\JPSoft\TCmd\Func.fil

Mr. Jiggs
TecDocDigital
s o l u t i o n s
p: (978) 567.6046
f: (978) 562.4304

-----Original Message-----
From: rconn [mailto:]
Sent: Monday, February 09, 2009 12:28 PM
To: Mr Jiggs
Subject: RE: [Support-t-921] Re: Take Command / TCMD/LE / TCC/LE
10.00.50 uploaded

---Quote (Originally by dcantor)---
Upon installation, starting this version gave me the choice window to
register or proceed with the notation that the trial ends in 30 days.
When I dismissed that window I got an error window.
---End Quote---

Not reproducible here - can you email me a copy of your TCMD.INI and
TCSTART (if any)?
 
G

Glennbo51

Guest
#11
I have been having the same problem. Here is my tcmd.ini and tcstart.btm

rconn wrote:

> ---Quote (Originally by dcantor)---
> Upon installation, starting this version gave me the choice window to register or proceed with the notation that the trial ends in 30 days. When I dismissed that window I got an error window.
> ---End Quote---
>
> Not reproducible here - can you email me a copy of your TCMD.INI and TCSTART (if any)?
>
>
>
>
>
>
 
G

Glennbo51

Guest
#12
I have been having the same problem. Here is my tcmd.ini and tcstart.btm

rconn wrote:
I see the files got stripped off so here goes

TCMD.INI
[4NT]
normaleditkey=f12
normalkey=f12
StartupFile=Yes
ExitFile=No
CompleteHidden=No
DebuggerTransparency=255
AutoCancel=Yes
AutoRun=Yes
BatchAliases=Yes
BatchEcho=No
CMDExtensions=No
CopyPrompt=No
DelayedExpansion=No
DelGlobalQuery=Yes
DirJunctions=Yes
DuplicateBugs=No
ExecWait=No
HistLogOn=No
LocalAliases=Yes
LocalDirHistory=No
LocalFunctions=Yes
LocalHistory=No
LogAll=No
LogOn=No
LogErrors=No
MouseWheel=Yes
NoClobber=No
PathExt=No
Perl=No
Python=No
RecycleBin=Yes
Rexx=Yes
Ruby=No
SettingChange=No
SHChangeNotify=No
TCStartPath="c:\program files\jpsoft\tcmd10"
UnicodeOutput=No
UnixPaths=No
UpdateTitle=Yes
Win32SFNSearch=No
Wow64FsRedirection=Yes
ZoneId=0
4StartPath="c:\program files\jpsoft\tcmd10"
ANSI=Yes
CDDWinLeft=454
CDDWinTop=124
CDDWinWidth=560
CDDWinHeight=216
ColorDir=DIRS:Bri whi on blu; com exe dll sys 386: bri cyan; bat btm cmd: bri red; bak: bri bla; c cpp h hpp bas frm vbp vbw cls clt frx: bri gre; doc xls: bri mag; zip: bri yel
ErrorColors=Bright Yellow on Magenta
PopupWinHeight=12
PopupWinTop=56
PopupWinLeft=164
PopupWinWidth=36
WindowHeight=0
WindowState=Standard
WindowWidth=0
WindowX=0
WindowY=0
Transparency=255
InactiveTransparency=255
AppendToDir=No
CompleteHiddenFiles=No
CompleteHiddenDirs=No
CompletePaths=No
CursorIns=85
CursorOver=15
DirHistory=32768
EditMode=Insert
FuzzyCD=3
HistMin=0
History=32768
HistCopy=No
HistDups=Last
HistMove=No
HistWrap=Yes
ServerCompletion=Local
TreePath=c:\
AmPm=No
BeepFreq=440
BeepLength=2
CommandSep=&
DecimalChar=Auto
DescriptionMax=512
NTFSDescriptions=No
Descriptions=Yes
EscapeChar=^
EvalMax=10
EvalMin=0
ExpandPseudovariables=Yes
ParameterChar=$
RegularExpressions=Perl
SwitchChar=/
TabStops=8
ThousandsChar=Auto
ProxyPort=80
FirewallType=None
PassiveFTP=Yes
FTPTimeout=60
HTTPTimeout=60
TFTPTimeout=60
MailPort=25
RLocalPort=0
SSLStartMode=0
SSLPort=0
[Debugger]
Docked=0
left=70
top=594
right=750
bottom=994
[TakeCommand]
CommandInput=No
StatusBar=Yes
StatusBarSize=No
StatusBarCPU=No
StatusBarLoad=No
StatusBarDate=No
StatusBarTime=No
COMSPEC="c:\program files\jpsoft\tcmd10\tcc.exe"
ConsoleBufferRows=5000
LeftAltKey=Yes
LeftCtrlKey=No
RightAltKey=No
RightCtrlKey=No
TabIcons=Yes
Tabs=Top
TabSize=100
TabX=Selected
CloseIfNoTabs=Yes
DescriptionMax=512
Descriptions=Yes
LinuxSelection=No
MinimizeOnClose=No
MouseWheel=Yes
NTFSDescriptions=No
PathExt=No
RegularExpressions=Perl
SettingChange=Yes
SHChangeNotify=Yes
ShowHiddenFiles=No
ShowSysFiles=No
ShowSuperHidden=No
SingleClick=No
ShowExtensions=Yes
UpdateTitle=No
Wow64FsRedirection=Yes
ZoneId=0
AlwaysOnTop=No
AppendToDir=No
CompleteHiddenFiles=Yes
CompleteHiddenDirs=Yes
CompletePaths=No
IBeamCursor=No
InactiveTransparency=255
ServerCompletion=Local
SingleInstance=Yes
Transparency=255
Tray=No
WindowState=Maximize
[Font]
font=Lucida Console
size=-11
weight=700
italic=0
Script=0

[ListView]
Style=1
[EnvironmentVariables]
Docked=0
left=150
top=150
right=650
bottom=550
[Watch]
Name=110
Height=110
[PopupFont]
Font=Lucida Console
Size=-11
Weight=700
Italic=0
Script=0
[Tab1]
Title=
Command=
Directory=
RunAs=
Password=
Admin=0
[Buttons]
B1=4,C:\Program Files\Microsoft Office\Office12\WINWORD.EXE,Word!,,"C:\Program Files\Microsoft Office\Office12\WINWORD.EXE"
B2=4,C:\Program Files\Microsoft Office\Office12\EXCEL.EXE,Excel,,"C:\Program Files\Microsoft Office\Office12\EXCEL.EXE"
B3=5,C:\Program Files\Microsoft Visual Studio\VB98\Wizards\PDWizard\PDCMDLN.EXE,Wiz,,""C:\Program Files\Microsoft Visual Studio\VB98\Wizards\PDWizard\PDCMDLN.EXE"" enter
B4=5,C:\Program Files\Microsoft Visual Studio\VB98\VB6.EXE,VB6,,""C:\Program Files\Microsoft Visual Studio\VB98\VB6.EXE"" enter
B5=5,C:\Program Files\Microsoft Visual Studio 8\Common7\IDE\devenv.exe,VSNET,,""C:\Program Files\Microsoft Visual Studio 8\Common7\IDE\devenv.exe"" enter
B6=5,C:\CONNX32\UTILS\Vbdemo32.exe,VBD,,"C:\CONNX32\UTILS\Vbdemo32.exe" enter
B7=5,C:\Program Files\Project Analyzer\PROJECT.EXE,Anal,,""C:\Program Files\Project Analyzer\PROJECT.EXE"" enter
B8=5,C:\CONNX\UTILS\CONNXCDD.EXE,CNX,,"C:\CONNX\UTILS\CONNXCDD.EXE" enter
B9=4,C:\Program Files\FileZilla FTP Client\filezilla.exe,FTP,,"C:\Program Files\FileZilla FTP Client\filezilla.exe"
B10=4,C:\Program Files\WinZip\WINZIP32.EXE,WinZip,,"C:\Program Files\WinZip\WINZIP32.EXE"
B11=4,C:\Program Files\Roxio\Easy Media Creator 7\Home Page\HomePageApp.exe,Rox,,"C:\Program Files\Roxio\Easy Media Creator 7\Home Page\HomePageApp.exe"
B12=4,C:\Program Files\IDM Computer Solutions\UltraEdit-32\uedit32.exe,UE,,"C:\Program Files\IDM Computer Solutions\UltraEdit-32\uedit32.exe"
B13=4,C:\Program Files\UltraCompare\UC.exe,UC,,"C:\Program Files\UltraCompare\UC.exe"
B14=4,C:\Program Files\VMware\VMware Workstation\vmware.exe,VM,,"C:\Program Files\VMware\VMware Workstation\vmware.exe"
B15=4,C:\Program Files\Zune\Zune.exe,Zune,,""C:\Program Files\Zune\Zune.exe""
B16=4,C:\Program Files\Mozilla Firefox\firefox.exe,FF,,"C:\Program Files\Mozilla Firefox\firefox.exe"
B17=4,C:\Program Files\Mozilla Thunderbird\thunderbird.exe,TB,,"C:\Program Files\Mozilla Thunderbird\thunderbird.exe"
B18=4,C:\Program Files\Reflection\r2win.exe,VA,,"C:\Documents and Settings\Gbowes\My Documents\bcsva.r2w"
B19=4,C:\Program Files\UltraVNC\vncviewer.exe,VNC,,"C:\Program Files\UltraVNC\vncviewer.exe"
B20=4,C:\sysinternals\procexp.exe,PE,,"C:\sysinternals\procexp.exe"
B21=4,C:\Program Files\Norton Save and Restore\Console\VProConsole.exe,NS,,"C:\Program Files\Norton Save and Restore\Console\VProConsole.exe"
B22=4,C:\Program Files\AVG\AVG8\avgui.exe,AVG,,"C:\Program Files\AVG\AVG8\avgui.exe"
B23=5,,261,,"\development\Fpss2611\" ENTER
B24=5,,Fpss,,"Fpss.vbp" enter
B25=4,C:\Program Files\JPSoft\TCCLE10\tcc.exe,TCC/LE,,"C:\Program Files\JPSoft\TCCLE10\tcc.exe"

TCSTART.BTM
iff %_transient = 0 then
alias /r c:\utils\aliases.dat
path %path%;c:\utils;"c:\program files\jpsoft\tcmd10";
set prompt=$+$$$s
set titleprompt=$p
set TreeExclude=k:\;l:\;p:\;s:\;u:\;v:\;x:\;y:\;z:\;c:\recoverybin\
endiff
 
May 29, 2008
533
3
Groton, CT
#13
Not reproducible here - can you email me a copy of your TCMD.INI and TCSTART (if any)?

I sent TCMD.INI, and did some more tests:

1. I removed TCSTART.BAT (and there is no TCSTART.BTM nor .CMD)

TCC started correctly, TC failed as before.

2. I removed TCMD.INI

TCC started correctly, TC failed as before.

The failures all had the same error information. No difference whatsoever.
 
Jun 6, 2008
1
0
#14
I installed into the same folder where I had version 9 installed (C:\JPSoft\TCMD). Got the "register" dialog, registered (successfully) and then got the MS "encountered a problem" dialog. Did an Uninstall (via Add/Remove) and Reinstall. Same result. TCMD won't start, but TCC.exe seems to be okay.

Win XPpro SP3
Mr. Jiggs

I seem to be having pretty much the same issue. I installed, got the registration message, then nothing. I didn't even get an MS error. Running procmon, the only errors I see are related to not finding default icons entries in the registry. Then it starts creating the tcmd.gpf and dies.

TCMD.gpf:

TCMD 10.00.50
Module=C:\Program Files\JPSoft\TCMD10\tcmd.exe
Address=0044A893
Exception=C0000005
EAX=00000000 EBX=00000001 ECX=00000000 EDX=0063FCCC
ESI=005C5244 EDI=0000BC4E EBP=002CF7D8 ESP=002CF7C8
CS=0000001B DS=00000023 ES=00000023 SS=00000023
Flags=00010246
Stack:
1 : tcmd.exe 0001:00049893
2 : tcmd.exe 0001:0004cc7e
3 : tcmd.exe 0001:0004f22a
4 : tcmd.exe 0001:00143ec3
5 : tcmd.exe 0001:001440a3
6 : tcmd.exe 0001:0014995f
7 : tcmd.exe 0001:001475e0
8 : tcmd.exe 0001:00147cf0
 
May 29, 2008
533
3
Groton, CT
#15
I seem to be having pretty much the same issue. I installed, got the registration message, then nothing. I didn't even get an MS error. Running procmon, the only errors I see are related to not finding default icons entries in the registry. Then it starts creating the tcmd.gpf and dies.

TCMD.gpf:

TCMD 10.00.50
Module=C:\Program Files\JPSoft\TCMD10\tcmd.exe
Address=0044A893
Exception=C0000005
EAX=00000000 EBX=00000001 ECX=00000000 EDX=0063FCCC
ESI=005C5244 EDI=0000BC4E EBP=002CF7D8 ESP=002CF7C8
CS=0000001B DS=00000023 ES=00000023 SS=00000023
Flags=00010246
Stack:
1 : tcmd.exe 0001:00049893
2 : tcmd.exe 0001:0004cc7e
3 : tcmd.exe 0001:0004f22a
4 : tcmd.exe 0001:00143ec3
5 : tcmd.exe 0001:001440a3
6 : tcmd.exe 0001:0014995f
7 : tcmd.exe 0001:001475e0
8 : tcmd.exe 0001:00147cf0
I didn't know about TCMD.GPF before, so I looked for it. It is EXACTLY the same with the exception of these two values:

EBP=002E8030 ESP=002E8020
 

rconn

Administrator
Staff member
May 14, 2008
10,779
97
#16
Could those of you who've reported a problem starting Take Command build 50 try grabbing the tcmd.exe in the ftp beta area (ftp://jpsoft.com/beta/tcmd.exe) and see if it fixes your startup problem? It's the tcmd executable, not the installer, so just copy it over your existing 10.00.50 installation.

Thanks!
 
May 20, 2008
457
2
#17
Could those of you who've reported a problem starting Take Command build 50 try grabbing the tcmd.exe in the ftp beta area (ftp://jpsoft.com/beta/tcmd.exe) and see if it fixes your startup problem? It's the tcmd executable, not the installer, so just copy it over your existing 10.00.50 installation.
It starts fine for me in Win7.
 
#18
The build 51 version starts on my system (WinXPpro SP3), though it takes
over 20 seconds to appear.
I do have a lot of mapped network connections.
The real bottom line is that I rarely use TCmd, but prefer TCC.

Thanks.

Mr. Jiggs
TecDocDigital
s o l u t i o n s
p: (978) 567.6046
f: (978) 562.4304

-----Original Message-----
From: rconn [mailto:]
Sent: Monday, February 09, 2009 10:07 PM
To: Mr Jiggs
Subject: RE: [Support-t-921] Re: Take Command / TCMD/LE / TCC/LE
10.00.50 uploaded

Could those of you who've reported a problem starting Take Command build
50 try grabbing the tcmd.exe in the ftp beta area
(ftp://jpsoft.com/beta/tcmd.exe) and see if it fixes your startup
problem? It's the tcmd executable, not the installer, so just copy it
over your existing 10.00.50 installation.

Thanks!