TCC: Disabling alias expansion with '*'

  • This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
#1
(TCC 11.00.47 running under Win 7)

Under the old 4NT, I had this alias:

copy=*copy /r​

and then if I wanted in a .btm file or at the command line to ensure that I got a copy/update without query, the command would be:

*copy /u filename destination\​

Under TakeCommand I have the same alias for "copy" but a copy command like the one shown just above still results in a query about overwriting the destination file.

How can I avoid the query?

The online help notes:

You can prevent alias expansion by using an asterisk before a command that you enter at the command line or in a batch file. This can be useful when you want to be sure you are running the original command and not an alias with the same name, or temporarily defeat the purpose of an alias which changes the meaning or behavior of a command.

I would interpret this to mean that using "*" does disable the alias temporarily. But it isn't working. Probably some simple dumb*** user error...but what's the error? TIA...
.
 

Charles Dye

Super Moderator
Staff member
May 20, 2008
3,415
40
Albuquerque, NM
prospero.unm.edu
#2
... and then if I wanted in a .btm file or at the command line to ensure that I got a copy/update without query, the command would be:
*copy /u filename destination\​
Under TakeCommand I have the same alias for "copy" but a copy command like the one shown just above still results in a query about overwriting the destination file.

How can I avoid the query?
Add a /Y to your command line, or turn off "Copy Prompt on Overwrite" (OPTION command, first tab, right-hand column, fifth line down.)