TCC prompt background color

Jul 30, 2014
2
0
(TCMD21 64-bit on WIndows 10)
I am having problems once again figuring out how to have my custom background color in a TCC prompt stay in effect. I change it to dark blue and the entire window gets that color--until a command causes the window to scroll, and then any space past the right of displayed text has a black color again. I saw this in older versions of TCMD but do not remember if I fixed it or if a later release fixed it.
 

Charles Dye

Super Moderator
Staff member
May 20, 2008
3,846
48
Albuquerque, NM
prospero.unm.edu
One way to fill the entire buffer is via CLS /C:
Code:
cls /c bright white on blue
You can put something like this in your TCSTART.BTM file and it will be performed every time you start TCC. (Edit: After checking for transient shells and pipes!)
 
May 20, 2008
9,348
62
Syracuse, NY, USA
You want the same background color al the time, right? Then set it in two places ... (1) in the console's properties (Alt-Space,P) and (2) in TCC's Option dialog (Windows tab).
 
Dec 7, 2009
225
2
Left Coast, USA
Vefatica nailed it. I used to have that problem and it drove me crazy until I decided to try changing the color in both "places," as he suggested. Solved.
 
Jul 30, 2014
2
0
Well, I did not have to change anything, because this is mysteriously working for me now. Weird. Maybe a machine reboot solved something. Anyway, thanks for the response. I will bookmark this for later reference if this comes up again.