1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

tcchere.btm not working on windows 7

Discussion in 'TCC/LE Support' started by zermelo, Apr 3, 2013.

  1. zermelo

    Joined:
    Apr 3, 2013
    Messages:
    3
    Likes Received:
    0
    I'm using TCC LE 13.06.75 x64 on Windows 7 [Version 6.1.7601].
    Today I have run tcchere.btm, but it crashed the command box. Unfortunatly the crash is so fast that I cannot see the specific error message.
     
  2. rconn

    rconn Administrator
    Staff Member

    Joined:
    May 14, 2008
    Messages:
    10,092
    Likes Received:
    85
    I doubt it's crashing -- it's probably exiting the session because you didn't have sufficient privileges. TCCHERE.BTM has to be run in an elevated session - right click on the TCC/LE icon, and select "run as administrator".
     
  3. zermelo

    Joined:
    Apr 3, 2013
    Messages:
    3
    Likes Received:
    0
    Authorizations are right.
    I was able to capture the error:

    Do you want to add a "TCC prompt here" entry to the Windows Explorer​
    context (right click) menus for directories and drives [Y/N] ?y​
    TCC: (Sys) C:\Program Files\JPSoft\TCCLE13x64\tcchere.btm [21] Parametro non corretto.​
    "%@regset["HKCR\Directory\Shell\TCC\",REG_SZ,TCC prompt here]"​
    C:\Program Files\JPSoft\TCCLE13x64\tcchere.btm [21] Uso : IFF [NOT] condizione [.AND. | .OR. | .XOR​
    . [NOT] condizione ...] THEN & comandi​
    Cannot update registry key!​
     
  4. rconn

    rconn Administrator
    Staff Member

    Joined:
    May 14, 2008
    Messages:
    10,092
    Likes Received:
    85
    That's the error you will get if the TCC session is not elevated.
     
  5. zermelo

    Joined:
    Apr 3, 2013
    Messages:
    3
    Likes Received:
    0
    You are right. Problem solved!
     

Share This Page