tcmd.ini not loading from program dir?

ccb

Jul 13, 2009
44
0
#1
TC v 17.00.70, Win7 x32

I have a symlink named tcmd.ini:
[C:\Program Files\JPSoft\TCMD17]dir *.ini
Volume in drive C is OSDisk Serial number is 38c4:518e
Directory of C:\Program Files\JPSoft\TCMD17\*.ini
2/19/2015 11:20 <SYMLINK> tcmd.ini [C:\Users\hxchba\OneDrive\jpsoft\v17\tcmd.ini]
1/16/2015 8:22 396 updater.ini


If I make configuration changes via Options->Take Command, a new .ini file is created in
C:\Users\hxchba\AppData\Local\JPSoft

What's going on? TC seems to ignore the tcmd.ini in tcmd17 dir.
(I have also tried creating a link with mklnk, and get the same result.)

Thanks for any insights --
 
#2
Works here:

Code:
g:\tc17> d *.ini
2015-02-18  11:14  4,512  my.ini
2014-10-25  22:09  2,353  tcconly.ini
2015-02-19  11:49  <SYMLINK>  tcmd.ini [my.ini]
2014-11-28  14:04  8,940  tcmdu.ini
2015-02-08  19:54  373  updater.ini

g:\tc17> echo %_ininame
G:\TC17\TCMD.INI
Try "ECHO %_ININAME" to see what INI file it's using.
 

ccb

Jul 13, 2009
44
0
#5
Not reproducible here (17.0.75, Win 8.1).

Are you passing a @xxx argument to TCC at startup?
Nope, just running "C:\Program Files\JPSoft\TCMD17\tcmd.exe".

Even w/o using a link -- tcmd.ini itself in the TCMD17 dir -- TakeCommand seems to ignore it.
Could there be some strange permissions issue w/r/t "C:\Program Files" ?
 

rconn

Administrator
Staff member
May 14, 2008
10,597
97
#6
TCMD and TCC look for the TCMD.INI file in this order:

1) The directory specified on the command line with the @tcmd.ini option (if any)
2) The TCC.EXE directory (not recommended in Win 7+ unless you always run elevated sessions)
3) The %LOCALAPPDATA directory

It might be a permissions issue; either you don't have read/write access to that file (or directory), or you're running non-elevated, and Windows doesn't allow non-elevated sessions to write to anything in "\Program Files".