tcmd.ini not loading from program dir?

ccb

Jul 13, 2009
47
0
TC v 17.00.70, Win7 x32

I have a symlink named tcmd.ini:
[C:\Program Files\JPSoft\TCMD17]dir *.ini
Volume in drive C is OSDisk Serial number is 38c4:518e
Directory of C:\Program Files\JPSoft\TCMD17\*.ini
2/19/2015 11:20 <SYMLINK> tcmd.ini [C:\Users\hxchba\OneDrive\jpsoft\v17\tcmd.ini]
1/16/2015 8:22 396 updater.ini


If I make configuration changes via Options->Take Command, a new .ini file is created in
C:\Users\hxchba\AppData\Local\JPSoft

What's going on? TC seems to ignore the tcmd.ini in tcmd17 dir.
(I have also tried creating a link with mklnk, and get the same result.)

Thanks for any insights --
 
May 20, 2008
11,411
99
Syracuse, NY, USA
Works here:

Code:
g:\tc17> d *.ini
2015-02-18  11:14  4,512  my.ini
2014-10-25  22:09  2,353  tcconly.ini
2015-02-19  11:49  <SYMLINK>  tcmd.ini [my.ini]
2014-11-28  14:04  8,940  tcmdu.ini
2015-02-08  19:54  373  updater.ini

g:\tc17> echo %_ininame
G:\TC17\TCMD.INI

Try "ECHO %_ININAME" to see what INI file it's using.
 

ccb

Jul 13, 2009
47
0
Not reproducible here (17.0.75, Win 8.1).

Are you passing a @xxx argument to TCC at startup?

Nope, just running "C:\Program Files\JPSoft\TCMD17\tcmd.exe".

Even w/o using a link -- tcmd.ini itself in the TCMD17 dir -- TakeCommand seems to ignore it.
Could there be some strange permissions issue w/r/t "C:\Program Files" ?
 

rconn

Administrator
Staff member
May 14, 2008
12,356
150
TCMD and TCC look for the TCMD.INI file in this order:

1) The directory specified on the command line with the @tcmd.ini option (if any)
2) The TCC.EXE directory (not recommended in Win 7+ unless you always run elevated sessions)
3) The %LOCALAPPDATA directory

It might be a permissions issue; either you don't have read/write access to that file (or directory), or you're running non-elevated, and Windows doesn't allow non-elevated sessions to write to anything in "\Program Files".
 
Similar threads
Thread starter Title Forum Replies Date
G Documentation on TCMD.INI Support 9
RChrismon How to? Copy TCMD.INI to New Version Support 7
D Custom ini-file is not read, by tcmd.exe cli Support 6
Alpengreis TCMD.INI: The "super hidden" problem ... Support 6
D Fresh instance of TCMD does not use TCMD.INI Support 7
C Optimum Placement for TCMD.ini and others? Support 6
cgunhouse Documentation Locating the TCMD.INI File Support 9
B Fixed Error messages from TCMD.INI Support 2
Detlef Fixed ParameterChar in TCMD.INI no longer working Support 35
Jay Sage How to Determine INI File Used by TCMD Support 6
cgunhouse TCMD.INI Issue Support 7
T TCTOOLBAR /C & TCTOOLBAR /I should reload toolbar from TCMD.INI, right? Support 1
T TCC reading TCMD.INI causing "Invalid item name" warnings and pauses Support 2
nickles Reload tcmd.ini from the command line Support 11
deleyd How to? Alias in TCMD.INI file? Support 2
J Extended directory search - cure by renaming tcmd.ini Support 10
A How to? How to enable UTF-8 output in tcmd.ini Support 9
C Env vars in tcmd.ini Support 12
S Location of tcmd.ini in x64 Support 4
williamleara Specifying path to TCMD.INI causes issues Support 8
C starting tcmd with alternate INI file Support 15
E Environment variable in tcmd.ini Support 14
C Chaining INI for TCMD 8, 9, and 10 Support 1
MickeyF equivalent to TCSTART.btm for TCMD? Support 4
D Bug TCMD /X option Support 6
vefatica TCMD hides itself! Support 3
vefatica Tray min'd TCMD and ACTIVATE Support 6
C How to? starting TCC/TCMD v25 Support 2
CWBillow TCC and TCMD in Powershell Support 6
kb6ojs How to? "Specified Account Already Exists" error installing TCMD v27 Support 12
CWBillow TCMD Colors Support 8
Jay Sage Issues With TCMD File Explorer Support 0
C Last TCMD that supports win 7? Support 5
gentzel TCMD background color confusion Support 6
R Upgrade TCMD 19 to TCC 26 Support 1
Alpengreis Remaining TCMD background process (v26) ... Support 19
S Windows Server version not being detected correctly in TCMD 26RC2 Support 9
G TCMD crash when copy Support 3
Joe Caverly DrawVLine results different in TCMD tab and detached TCC Support 11
Alpengreis [TCMD v25.00.24] Small space problem with the DE translation in Prefs-GUI Support 1
Alpengreis [TCMD v25.00.24] Problem with copy and paste and the # char via mouse in TCC Support 6
Jay Sage TCMD Crashes with "tctoolbar /c /r file" Support 5
nikbackm TCMD 25 - Unregister older TCMD version Support 2
R New Clear Buffer in TCMD Home Menu Support 2
CWBillow Back up TCMD tabs Support 2
CWBillow Upgrade Windows 10's effect on TCMD and TCC Support 3
DrusTheAxe TCMD 24.02.49 x64 crashed due to DivideByZero :-( Support 4
A After update to 24.02.49, helpfile tcmd.chm hangs when opened Support 0
David McClelland TCMD 24 & Perl - perl thinks it's own executable is ...\TCMD24\TCC.EXE??? Support 3
dcantor How to? Can 32-bit TCC be run on a system with 64-bit TCMD and TCC installed? Support 6

Similar threads