1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

TCMD takes very long to start up

Discussion in 'Support' started by ad1c, Jul 31, 2008.

  1. ad1c

    Joined:
    Jul 31, 2008
    Messages:
    19
    Likes Received:
    0
    If I click on my TCC icon (tcc.exe), the command window comes up almost instantaneously.

    If I instead click on my TC icon (tcmd.exe), it can be MANY SECONDS (10-30) before the TCC window comes up.

    This is on a Windows XP system running SP3 with 4GB of RAM and a Q6600 Intel quad core processor. Fast, large hard drive. Using Windows Live OneCare for protection.

    Anyone know what might be going on?

    Thanks - Jim
     
  2. Number8

    Joined:
    May 29, 2008
    Messages:
    5
    Likes Received:
    0
    I cut down TCMD's startup time by reducing the size of the history files it loads. I don't know what the difference would be between TC and TCC, though.
     
  3. p.f.moore

    Joined:
    May 30, 2008
    Messages:
    122
    Likes Received:
    1
    2008/7/31 ad1c <>:

    I find the slow startup is related to checking all the drives on the
    system (for the folder/list views). If you have slow network drives or
    CD/DVD drives, this may explain it. (I get around 6-10 sec, not
    10-30).

    This happens even if the list/folder views are hidden :-(

    Paul
     
  4. samintz

    samintz Scott Mintz

    Joined:
    May 20, 2008
    Messages:
    1,201
    Likes Received:
    11
    TCMD needs to populate its folder view when it starts up. So any obsolete
    or disconnected network drives will dramatically slow down TCMD's startup
    time.

    -Scott

    Number8 <> wrote on 07/31/2008 02:55:28 PM:


     
  5. joshjeppson

    Joined:
    Jun 2, 2008
    Messages:
    42
    Likes Received:
    0
    Do you have any mapped network drives?

    Take Command does some sort of costly iteration when it first starts that is very expensive for network drives.


    - Josh
     
  6. joshjeppson

    Joined:
    Jun 2, 2008
    Messages:
    42
    Likes Received:
    0
    They don't have to be obsolete or disconnected. I've seen this problem on a freshly rebooted system with only one network drive attached shortly before starting Take Command.
     
  7. ad1c

    Joined:
    Jul 31, 2008
    Messages:
    19
    Likes Received:
    0

    I do not have any mapped network drives. I do have C, D, E, F, G, I and P partitions. There are lots of files on the P drive (photos). I have a floppy and CD drive also.

    This might explain why it's so much faster at work, where I only have a C:\ drive, but do also have a couple of network drives.
     
  8. vefatica

    Joined:
    May 20, 2008
    Messages:
    8,053
    Likes Received:
    30
    On Thu, 31 Jul 2008 14:42:19 -0500, ad1c <> wrote:


    I disabled my floppy becxause of delays in TCMD. I don't use TCMD, except to
    test. I don't miss the floppy.
     
  9. Steve Fabian

    Joined:
    May 20, 2008
    Messages:
    3,520
    Likes Received:
    4
    ad1c wrote:
    | If I click on my TCC icon (tcc.exe), the command window comes up
    | almost instantaneously.
    |
    | If I instead click on my TC icon (tcmd.exe), it can be MANY SECONDS
    | (10-30) before the TCC window comes up.
    |
    | This is on a Windows XP system running SP3 with 4GB of RAM and a
    | Q6600 Intel quad core processor. Fast, large hard drive. Using
    | Windows Live OneCare for protection.
    |
    | Anyone know what might be going on?
    |
    | Thanks - Jim

    I just started TCMD in approximately 6 s, opening 6 tabs, most of them
    running programs not used since the last system start. Below is my system
    information, clipped from F. Romano's FEDUTILS plugin command SYSINFO:

    FedUtils System Information Utility 1.0.8 - 2006-04-11

    SYSTEM OVERVIEW

    ...
    System : ACPI Uniprocessor PC
    Model : eMachines Product Name
    CPU : 1 x AMD Sempron - 2166 MHz
    Cache: 128 KB L1 + 512 KB L2 + 0 KB L3
    Mainboard: First International Computer, Inc. AU31
    Memory : 959 MB
    Operating system: Windows XP Home Edition [5.1.2600]
    Service pack : 3.0

    If your system is that slow, you must attempt to access devices not mounted,
    or you have some other configuration problem.
    --
    Steve
     
  10. Steve Fabian

    Joined:
    May 20, 2008
    Messages:
    3,520
    Likes Received:
    4
    ad1c wrote:
    | I do not have any mapped network drives. I do have C, D, E, F, G, I
    | and P partitions. There are lots of files on the P drive (photos).
    | I have a floppy and CD drive also.

    Keep the number of entries in the root directory of each partition low. That
    may also reduce starting time.
    --
    HTH, Steve
     
  11. ad1c

    Joined:
    Jul 31, 2008
    Messages:
    19
    Likes Received:
    0
    I had tcmd set up to start in my Downloads folder which has 600+ files. I changed it to the root of the drive, and now it starts up quickly.

    Thanks for all the answers here.

    - Jim
     
  12. Steve Fabian

    Joined:
    May 20, 2008
    Messages:
    3,520
    Likes Received:
    4
    ad1c wrote:
    | I had tcmd set up to start in my Downloads folder which has 600+
    | files. I changed it to the root of the drive, and now it starts up
    | quickly.
    |
    | Thanks for all the answers here.

    You could use the TCSTART.BTM to move you into the DL directory after TCMD
    and its tabs started, which ought to have the same end result in a lot less
    time.

    BTW, my DL directory has many subdirectories, but itself contains fewer than
    100 files.
    --
    HTH, Steve
     
  13. tharen

    Joined:
    Aug 17, 2008
    Messages:
    1
    Likes Received:
    0
    I'd like to post my opinion that this behavior is causing much grief... just because we know that shares and folders might make things slow doesn't solve the problem. I can (and have) moved my start directory, but I cannot really change the list of shares. I'm smart enough to not use them most of the time... and while I can see the value for some to use the ListView and/or Folders they are always closed for me.

    Somehow deferring the population of this data or putting it in the background seems like a great idea... please!

    Thanks
     
  14. Arjan van Gog

    Joined:
    Feb 12, 2009
    Messages:
    17
    Likes Received:
    0
    I second this request. My TCMD sometimes takes quite long to start whereas Take Command/32 v3.01a always loads instantly. I use a CLI for speed (vs using Windows Explorer) so having to wait even just 10 seconds is very annoying (although I've had to wait as long as 30 seconds a few times).

    Either not initializing the Folder and List views when they are hidden or (perhaps better) using a separate background thread to populate them would be a very welcome feature.
     
  15. jurlwin

    Joined:
    Apr 4, 2009
    Messages:
    1
    Likes Received:
    0
    I third this request. Just tested with TCC 10 and it's still slow, when my laptop is home and can't connect.

    Do one of the lower level versions of TCC work around this and am I licensed to use a lower level version and the highest level?
     
  16. rconn

    rconn Administrator
    Staff Member

    Joined:
    May 14, 2008
    Messages:
    9,991
    Likes Received:
    84
    jurlwin wrote:

    Startup time has nothing to do with TCC.

    The delay is inside Windows when Take Command tries to populate the
    Folder view. This is considerably faster in the more recent v10 builds,
    except in the case where Take Command is trying to connect to an
    unavailable UNC share. That delay is in the Windows API, and I believe
    the internal Windows timeout is configurable.

    Rex Conn
    JP Software
     
  17. vefatica

    Joined:
    May 20, 2008
    Messages:
    8,053
    Likes Received:
    30
    On Sat, 04 Apr 2009 09:04:58 -0500, rconn <> wrote:

    |The delay is inside Windows when Take Command tries to populate the
    |Folder view. This is considerably faster in the more recent v10 builds,
    |except in the case where Take Command is trying to connect to an
    |unavailable UNC share. That delay is in the Windows API, and I believe
    |the internal Windows timeout is configurable.

    I found this (http://technet.microsoft.com/en-us/library/cc959773.aspx, below,
    re Windows 2000) ... still looking for an XP/Vista reference.

    ConnectTimeout
    HKLM\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters
    Data type
    Range
    Default value
    REG_DWORD
    0x0–0xFFFFFFFF ( seconds )
    0x12C ( 300 seconds = 5 minutes )
    Description
    Specifies the maximum amount of time the redirector waits for a connect or
    disconnect to complete.
    Note Image Note
    Windows 2000 does not add this entry to the registry. You can add it by editing
    the registry or by using a program that edits the registry.
    --
    - Vince
     
  18. dcantor

    Joined:
    May 29, 2008
    Messages:
    508
    Likes Received:
    3
    So would it be possible, Rex, for TC to skip the calls to the Windows API if the user's configuration has the folder and list views hidden? (This would probably require doing that setup later if the user selects to view the folder and list views, of course.)
     
  19. wcfi

    Joined:
    Aug 31, 2011
    Messages:
    13
    Likes Received:
    0
    Is there any update on this? I do not use the folder/list view at all and it becomes very frustrating when TC takes a long time to load due to missing network drives.
     
  20. rconn

    rconn Administrator
    Staff Member

    Joined:
    May 14, 2008
    Messages:
    9,991
    Likes Received:
    84
    It's on the suggestion list for a future version. (Unfortunately, it is
    exceedingly complex and requires rewriting several thousand lines of code.)
     

Share This Page