TCMD v10 - Python support - use version 2.6?

May 30, 2008
122
1
#1
The Python support in TCMD v10 is documented as using Python 2.5. As Python 2.6 is the latest version, and the current ActiveState Python is version 2.6, can the supported version in TCMD v10 be changed to 2.6? It should be little more than changing the version number of the DLL to be loaded.

Alternatively, could there be a configuration option to select the version (2.5 or 2.6) to use? Again, this could be as simple as an option specifying the name of the Python DLL.

As it stands, the new Python support is already obsolete :mad:

Paul

PS By the way - the help for @PYTHON is wrong, it says "@PERL[expression] : Executes the specified Python expression".
 

rconn

Administrator
Staff member
May 14, 2008
10,551
97
#2
p.f.moore wrote:

> The Python support in TCMD v10 is documented as using Python 2.5. As Python 2.6 is the latest version, and the current ActiveState Python is version 2.6, can the supported version in TCMD v10 be changed to 2.6? It should be little more than changing the version number of the DLL to be loaded.
>
> Alternatively, could there be a configuration option to select the version (2.5 or 2.6) to use? Again, this could be as simple as an option specifying the name of the Python DLL.
>
> As it stands, the new Python support is already obsolete :mad:
Unfortunately, the Python developers broke embedded Python support in
2.6.1 (while fixing another problem).

When I looked at it last there weren't any workarounds. I'll take a
look again and see if anybody has come up with a fix.

Rex Conn
JP Software