"The Specified Account Already Exists" - Can't Reinstall To Fix Protection Screw-Up of Last Week

  • This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
Jun 24, 2017
15
0
#1
So I'm trying to re-install TCC21 to fix the screw-up with the copy protection which happened last week. :|

My Windows 10 system is fine but the installer fails on my Windows 7 one with a cryptic "The specified account already exists" .. this happens during the "Copying new files" part.

I have no idea what it's on about, what account?

How do I fix it?
 
Jun 24, 2017
15
0
#2
I copied the installation from the Windows 10 system (ie. the TCC21 tree) to the Windows 7 system and in works, but I still would like to know why the installation failed, if I didn't have the Windows 10 system working my main PC would be hosed .. what account is the installer trying to create?
 
Jun 24, 2017
15
0
#5
I've tried uploading the installer log file but this forum software won't let me, it says 'LOG' files aren't allowed!

I tried looking through it to try to understand what failed but frankly it's so massive and there are several places with text such as 'fatalerror' that I don't know where to begin.
 
#7
All you need to do is to change the extension of the LOG file to one that is accepted by the forum software, which would be TXT. Or to compress it to a ZIP or 7ZIP file....
 
Jun 24, 2017
15
0
#8
Well I've now found the point in the log where it fails, and it smells suspiciously like 'Everything'!

MSI (s) (FC:C4) [19:10:55:213]: Executing op: ProgressTotal(Total=27754556,Type=0,ByteEquivalent=1)
MSI (s) (FC:C4) [19:10:55:213]: Executing op: SetTargetFolder(Folder=C:\Program Files\JPSoft\TCC21\)
MSI (s) (FC:C4) [19:10:55:213]: Executing op: SetSourceFolder(Folder=1\)
MSI (s) (FC:C4) [19:10:55:213]: Executing op: ChangeMedia(,MediaPrompt=Please insert the disk: ,,BytesPerTick=65536,CopierType=0,,,,,,IsFirstPhysicalMedia=1)
MSI (s) (FC:C4) [19:10:55:213]: Executing op: RegisterSharedComponentProvider(,,File=Everything.exe,Component={CCE4A56F-5A5C-46EF-9CFC-8C972D4A1A66},ComponentVersion=1.4.1.877,ProductCode={FCB877BA-BC4E-40DD-91A8-3166F856DB21},ProductVersion=21.1.47,PatchSize=0,PatchAttributes=0,PatchSequence=0,SharedComponent=0,IsFullFile=0)
MSI (s) (FC:C4) [19:10:55:217]: Executing op: FileCopy(SourceName=EVERYT~1.EXE|Everything.exe,SourceCabKey=Everything.exe,DestName=Everything.exe,Attributes=0,FileSize=2197608,PerTick=65536,,VerifyMedia=1,,,,,CheckCRC=0,Version=1.4.1.877,Language=1033,InstallMode=58982400,,,,,,,)
MSI (s) (FC:C4) [19:10:55:217]: File: C:\Program Files\JPSoft\TCC21\Everything.exe; To be installed; Won't patch; No existing file
MSI (s) (FC:C4) [19:10:55:217]: Resolving source.
MSI (s) (FC:C4) [19:10:55:217]: Resolving source to launched-from source.
MSI (s) (FC:C4) [19:10:55:217]: Setting launched-from source as last-used.
MSI (s) (FC:C4) [19:10:55:217]: PROPERTY CHANGE: Adding SourceDir property. Its value is 'C:\Windows\Installer\'.
MSI (s) (FC:C4) [19:10:55:217]: PROPERTY CHANGE: Adding SOURCEDIR property. Its value is 'C:\Windows\Installer\'.
MSI (s) (FC:C4) [19:10:55:217]: PROPERTY CHANGE: Adding SourcedirProduct property. Its value is '{FCB877BA-BC4E-40DD-91A8-3166F856DB21}'.
MSI (s) (FC:C4) [19:10:55:217]: SOURCEDIR ==> C:\Windows\Installer\
MSI (s) (FC:C4) [19:10:55:217]: SOURCEDIR product ==> {FCB877BA-BC4E-40DD-91A8-3166F856DB21}
MSI (s) (FC:C4) [19:10:55:217]: SECREPAIR: CryptAcquireContext succeeded
MSI (s) (FC:C4) [19:10:55:217]: Determining source type
MSI (s) (FC:C4) [19:10:55:217]: Note: 1: 2203 2: C:\Windows\Installer\tcc.x64.msi 3: -2147287038
MSI (s) (FC:C4) [19:10:55:217]: Note: 1: 1316 2: C:\Windows\Installer\tcc.x64.msi
MSI (s) (FC:C4) [19:10:55:217]: SECREPAIR: Error determining package source type
MSI (s) (FC:C4) [19:10:55:217]: SECUREREPAIR: SecureRepair Failed. Error code: 524EBF044B8
Error 1316. The specified account already exists.

MSI (s) (FC:C4) [19:10:59:503]: Product: TCC 21 -- Error 1316. The specified account already exists.

I selected NOT to install it, so why does it still try? "MSI (s) (FC:C4) [19:10:55:217]: File: C:\Program Files\JPSoft\TCC21\Everything.exe; To be installed; Won't patch; No existing file"
 
#9
Even if you don't run Everything or install it as a service, TCC uses it and certainly needs the Everything DLL. It probably puts the Everything EXE in place as a matter of course.