TPIPE /REPLACE - Remove line (including EOL)

x13

Nov 9, 2016
76
1
Netherlands
Hi all.

I haven't been able to figure this out.

I have a text file containing variable length phrases (no line wrap).
I want to remove a specific line including its EOL from the file, but it doesn't work.

I tried :

TPIPE /INPUT=in.txt /OUTPUT=out.txt /REPLACE=0,0,0,0,0,0,0,1,0,"keysize 256","" (works but leaves a blank line)

TPIPE /INPUT=in.txt /OUTPUT=out.txt /REPLACE=0,0,0,0,0,0,0,1,0,"keysize 256\n","" nope
TPIPE /INPUT=in.txt /OUTPUT=out.txt /REPLACE=0,0,0,0,0,0,0,1,0,"keysize 256^m","" nope
TPIPE /INPUT=in.txt /OUTPUT=out.txt /REPLACE=0,0,0,0,0,0,0,1,0,"keysize 256^m^j","" nope
TPIPE /INPUT=in.txt /OUTPUT=out.txt /REPLACE=0,0,0,0,0,0,0,1,0,"keysize 256**","" nope (with actual CR+LF)
TPIPE /INPUT=in.txt /OUTPUT=out.txt /REPLACE=0,0,0,0,0,0,0,1,0,"keysize 256↑*↑*","" nope (with actual CR+LF, preceded by <EscChar>)

TPIPE /INPUT=in.txt /OUTPUT=out.txt /REPLACE=4,0,0,0,0,0,0,1,0,"s/keysize 256\n/","" PERL, still no
TPIPE /INPUT=in.txt /OUTPUT=out.txt /REPLACE=4,0,0,0,0,0,0,1,0,"~/keysize 256\n/","" PERL, still no

Help mentions you can configure the EOL character and whether it is displayed (I assume in TCMD.ini).
But how can I make TPIPE understand that I want the EOL character to also be removed?

A typical substitute command would look like: s/keysize 256^p// (^p, ^m or whatever is valid for context)

I'm sure it's stupid but I don't see it.

It's a shame that help file doesn't contain more in-depth info on TPIPE... (external site?)

Thanks.

x13
 
May 20, 2008
11,285
95
Syracuse, NY, USA
You can do it with /replace (see below) but /replace probably knows nothing about lines and you'll have to specify the CRLF. /grep works with lines and is the better choice. Either way, use a regex to specify the whole line.
Code:
v:\> type threelines.txt
My dog has fleas.
My cat has worms.
My bird has ticks.

v:\> tpipe /input=threelines.txt /replace=4,0,0,0,0,0,0,0,0,"^.*cat has.*\r\n",""
My dog has fleas.
My bird has ticks.

v:\> tpipe /input=threelines.txt /grep=4,0,0,0,0,0,0,0,"^.*cat has.*$"
My dog has fleas.
My bird has ticks.
 
May 20, 2008
11,285
95
Syracuse, NY, USA
(doh!) Since grep works with whole lines, you can simplify that last one. Just make sure you give enough text to pick only the line you want to remove.

Code:
v:\> type threelines.txt
My dog has fleas.
My cat has worms.
My bird has ticks.

v:\> tpipe /input=threelines.txt /grep=4,0,0,0,0,0,0,0,"cat has"
My dog has fleas.
My bird has ticks.
 
Similar threads
Thread starter Title Forum Replies Date
MickeyF Can't get my TPIPE /replace to work Support 4
vefatica Back-refs in TPIPE's /replace's replacement string? Support 2
vefatica TPIPE /replace? Support 3
samintz How to? TPIPE /simple=61 Support 6
R Bug TPIPE's pdf to text conversions don't work Support 2
Kachupp How to? tpipe Support 4
H TPIPE /simple=4 Support 12
D TPIPE produces unwanted logs. Support 1
Kachupp How to? tpipe Support 8
vefatica Documentation TPIPE, /perl, DotMatchesNewLines Support 1
vefatica Stop TPIPE /EOL removing bad EOLs (and TPIPE changine EOLs)? Support 2
vefatica TPIPE in an alias? Support 2
C How to? TPIPE ?'s Support 2
H History and TPipe Oddness Support 3
Jay Sage Baffling Behavior With TPIPE Support 5
vefatica TPIPE: unbalanced escaped quotes in a regex? Support 5
Joe Caverly Multiple Text Searches at once using FFIND or TPIPE Support 4
Kachupp FFIND TPIPE Support 9
vefatica TPIPE and avarice? Support 5
Peter Murschall TPIPE generate unicode on Piping or redirecting Support 3
Charles Dye Documentation TPIPE /REPLACELIST Support 0
Joe Caverly TPIPE and /inputstring Support 3
vefatica How to? Add real <ESC> characters with TPIPE Support 2
vefatica How to? TPIPE ... see output right away? Support 4
vefatica TPIPE.EXE crashes on Ctrl-C Support 9
O TPIPE: Error -Can´t access textpipeengine.dll Support 24
vefatica Extract fields with TPIPE? Support 10
vefatica TPIPE, crash and question Support 1
MickeyF Another TPIPE question Support 6
Joe Caverly Printing TPIPE documentation Support 3
C WAD tpipe /simple=28 Support 8
vefatica Remove double-quotes with TPIPE Support 4
vefatica TPIPE crashes on Ctrl-C Support 1
C How to? Add date/time to custom tpipe based BTM Support 1
C tpipe /simple=28 error Support 5
C TPipe /dup Support 5
T TPipe: Replacing String with Double Quotes Support 3
C tpipe and extract email addresses Support 1
vefatica How do I do this with TPIPE? Support 1
vefatica TPIPE's /perl option? Support 1
D TPIPE help typo Support 0
vefatica TPIPE access violations are back Support 2
Joe Caverly Word Count using TPIPE Support 10
Dan Glynhampton TPIPE in Build 41 Support 4
Phileosophos TPIPE doesn't work at all with v16 Support 3
vefatica TPIPE access violation again Support 1
David McClelland TPIPE matching problem Support 3
vefatica TPIPE: Access violation Support 5
jbanaszczyk TCMD 16 - TPIPE Support 4
P TPipe relaunches TCC window and 4start, etc Support 7

Similar threads