WAD tpipe /simple=28

Apr 2, 2011
1,404
10
54
North Carolina, USA
I have exported my gmail address book to a CSV file and trying to extract the email addresses. This is the header information for the file:

Code:
First Name,Middle Name,Last Name,Title,Suffix,Initials,Web Page,Gender,Birthday,Anniversary,Location,Language,Internet Free Busy,Notes,E-mail Address,E-mail 2 Address,E-mail 3 Address,Primary Phone,Home Phone,Home Phone 2,Mobile Phone,Pager,Home Fax,Home Address,Home Street,Home Street 2,Home Street 3,Home Address PO Box,Home City,Home State,Home Postal Code,Home Country,Spouse,Children,Manager's Name,Assistant's Name,Referred By,Company Main Phone,Business Phone,Business Phone 2,Business Fax,Assistant's Phone,Company,Job Title,Department,Office Location,Organizational ID Number,Profession,Account,Business Address,Business Street,Business Street 2,Business Street 3,Business Address PO Box,Business City,Business State,Business Postal Code,Business Country,Other Phone,Other Fax,Other Address,Other Street,Other Street 2,Other Street 3,Other Address PO Box,Other City,Other State,Other Postal Code,Other Country,Callback,Car Phone,ISDN,Radio Phone,TTY/TDD Phone,Telex,User 1,User 2,User 3,User 4,Keywords,Mileage,Hobby,Billing Information,Directory Server,Sensitivity,Priority,Private,Categories

This is the data line that tpipe gives an incorrect address:

Code:
Alison,,P,,,,,,,,,,,,alison.p0001@yahoo.com,,,,,,1112223333,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,Normal,,My Contacts,

and the result tpipe gives is:

Code:
Alison,,P,,,,,,,,,,,,alison.p0001@yahoo.com
 
May 20, 2008
11,292
95
Syracuse, NY, USA
Agreed, it's a bug. It works correctly if the comma-separated values are quoted (common, but not necessary). Elsewhere (see /simple=50) TPIPE can handle CSV data "quoted or unquoted".
 
May 20, 2008
11,292
95
Syracuse, NY, USA
P.S., Commas are allowed in email addresses, but then only in the local part AND only in a quoted string.
 
Apr 2, 2011
1,404
10
54
North Carolina, USA
@vefatica,

I recall an earlier discussion where the rules for email addresses was menioned - with a HTML link. Do you recall what it was?

I also did /simple=50 then /simple=28 and it's still not working correctly.....
 
Apr 2, 2011
1,404
10
54
North Carolina, USA
I am attaching the contacts.csv ZIPed, and still have the orginal problem -

I tried both
tpipe /input=contacts.csv /simple=56 /simple=28 /outputappend=1 /output=outfile2.txt
tpipe /input=contacts.csv /simple=50 /simple=28 /outputappend=1 /output=outfile1.txt

and makes no difference...
 

Attachments

  • contacts.zip
    13.2 KB · Views: 69
May 20, 2008
11,292
95
Syracuse, NY, USA
That csv file is screwed up. Nothing works beyond this line ...
Code:
FullContact,,Support,,,,,,,,,,,,support@fullcontact.com,,,,,,,,,,,,,,,,,,,,,,,,,,,,FullContact,,,,,,,"Denver, CO
... which has an opening quote and no closing quote.
Remove that double-quote and it's OK here.
 
Apr 2, 2011
1,404
10
54
North Carolina, USA
Thank you Vince. I guess I need to contact Google contact support.

I guess it would be the same difference if I removed the double quote or added one at the EOL....???
 
Similar threads
Thread starter Title Forum Replies Date
C tpipe /simple=28 error Support 5
samintz How to? TPIPE /simple=61 Support 6
R Bug TPIPE's pdf to text conversions don't work Support 2
Kachupp How to? tpipe Support 4
H TPIPE /simple=4 Support 12
D TPIPE produces unwanted logs. Support 1
Kachupp How to? tpipe Support 8
vefatica Documentation TPIPE, /perl, DotMatchesNewLines Support 1
vefatica Stop TPIPE /EOL removing bad EOLs (and TPIPE changine EOLs)? Support 2
vefatica TPIPE in an alias? Support 2
C How to? TPIPE ?'s Support 2
H History and TPipe Oddness Support 3
Jay Sage Baffling Behavior With TPIPE Support 5
vefatica TPIPE: unbalanced escaped quotes in a regex? Support 5
Joe Caverly Multiple Text Searches at once using FFIND or TPIPE Support 4
Kachupp FFIND TPIPE Support 9
vefatica TPIPE and avarice? Support 5
Peter Murschall TPIPE generate unicode on Piping or redirecting Support 3
x13 TPIPE /REPLACE - Remove line (including EOL) Support 3
Charles Dye Documentation TPIPE /REPLACELIST Support 0
Joe Caverly TPIPE and /inputstring Support 3
vefatica How to? Add real <ESC> characters with TPIPE Support 2
vefatica How to? TPIPE ... see output right away? Support 4
vefatica TPIPE.EXE crashes on Ctrl-C Support 9
O TPIPE: Error -Can´t access textpipeengine.dll Support 24
vefatica Extract fields with TPIPE? Support 10
vefatica TPIPE, crash and question Support 1
MickeyF Another TPIPE question Support 6
MickeyF Can't get my TPIPE /replace to work Support 4
Joe Caverly Printing TPIPE documentation Support 3
vefatica Remove double-quotes with TPIPE Support 4
vefatica TPIPE crashes on Ctrl-C Support 1
C How to? Add date/time to custom tpipe based BTM Support 1
C TPipe /dup Support 5
T TPipe: Replacing String with Double Quotes Support 3
C tpipe and extract email addresses Support 1
vefatica How do I do this with TPIPE? Support 1
vefatica TPIPE's /perl option? Support 1
D TPIPE help typo Support 0
vefatica TPIPE access violations are back Support 2
Joe Caverly Word Count using TPIPE Support 10
Dan Glynhampton TPIPE in Build 41 Support 4
Phileosophos TPIPE doesn't work at all with v16 Support 3
vefatica TPIPE access violation again Support 1
David McClelland TPIPE matching problem Support 3
vefatica TPIPE: Access violation Support 5
jbanaszczyk TCMD 16 - TPIPE Support 4
P TPipe relaunches TCC window and 4start, etc Support 7
Phileosophos Documentation TPIPE /string type code confusion Support 4
C TPIPE questions.... Support 5

Similar threads