Transparency in IDE not working correctly

Aug 16, 2008
124
0
Every time I start IDE it starts semi-transparent. I believe it gets its setting from TC where I set it to 207. Turning off transparency in IDE by putting the slider at the bottom right to the far left works but on the next start IDE is again semi-transparent.

Basically what I would like to have is IDE to
1. retain the transparency setting I made manually and
2. maintain it seperately from TC

Thorsten
TC 12.10 latest version
 

rconn

Administrator
Staff member
May 14, 2008
12,344
149
Every time I start IDE it starts semi-transparent. I believe it gets its setting from TC where I set it to 207. Turning off transparency in IDE by putting the slider at the bottom right to the far left works but on the next start IDE is again semi-transparent.

The IDE transparency is separate from the TCMD transparency. It is set by the "DebuggerTransparency" directive in the 4NT section of TCMD.INI.

The slider only sets the transparency for the current session, and is not saved on exit. This is by design, as that's what most users preferred.
 
Aug 16, 2008
124
0
That fixed it. Although I heavily doubt that most users want to reconfigure their IDE every time they start it (or have to hack the ini file)
 

Charles Dye

Super Moderator
Staff member
May 20, 2008
4,460
88
Albuquerque, NM
prospero.unm.edu
I don't know whether this is feasible or reasonable, but:

Perhaps the slider controls could distinguish between a drag and a control-drag; e.g. dragging the slider might just change the transparency in the current instance, but dragging the slider while holding Control might change the transparency and write the new value to the .INI file.
 
Similar threads
Thread starter Title Forum Replies Date
Kachupp IDE watch references Support 11
T Thanks for the assistance with IDE vs Bdebugger Support 3
vefatica IDE external command syntax color? Support 1
K_Meinhard Small problem in german IDE 26 Support 3
vefatica IDE - when breakpoint is on a blank line? Support 3
Peter Murschall IDE: After undocking the command expansion Window is offended Support 2
Peter Murschall IDE: Ctrl-W is a Harakiri Command ! Support 23
Kachupp ide/bdebugger Support 17
rps IDE/BDEBUGGER ? Support 1
vefatica IDE.EXE's command line? Support 19
Peter Murschall IDE: RTL with non-English resources-problem is back in Build 28 Support 4
Peter Murschall v24 IDE/BDEBUGGER won't start Support 9
vefatica IDE stuck on "Insert tabs as spaces" Support 0
Peter Murschall IDE/BDEBUUGER in TCC 22 didn't run Support 7
T Fixed Problem with use of Batch parameters in the IDE Support 1
T Fixed IDE locks up if edit window for running batch is closed Support 6
Peter Murschall IDE destroys Text on Ctrl-U/Ctrl-Shift-U Support 12
C BDEBUGGER/IDE crashing Support 1
vefatica Monospace font in IDE? Support 3
vefatica IDE crashes every time Support 6
R TCC IDE Tabs - inactive tabs hard to see Support 14
vefatica IDE crashing Support 11
vefatica Why doesn't "IDE %_ININAME" work? Support 4
vefatica IDE's dynamic help ... Support 0
vefatica Contuing IDE gripes Support 11
vefatica WAD IDE, output window to foreground Support 3
vefatica Fixed IDE weirdness Support 3
vefatica IDE double-click select? Support 29
vefatica Doesn't IDE auto-indent? Support 3
T bdebugger / ide usage confusion Support 14
vefatica Fixed Font corruption in IDE Support 3
vefatica IDE status bar row/column? Support 0
vefatica An IDE anomaly Support 2
T Associating BTM files with IDE results in DOS box Support 33
S WAD IDE /C does not accept truename of future file Support 13
S How to? Is it possible for the IDE to start without plugins? Support 3
S Documentation "HELP IDE" - missing reference Support 0
Mordachai Fixed Closing TCMD while IDE + Help Open = Crash Support 7
jwiede ide.exe not launching? Support 13
F No ide.exe or tcmd.exe files - Win7 64bit Support 5
T Syntax highlighting in the IDE Support 8
Frank watch an array variable in ide/bdebugger Support 2
Peter Murschall Is IDE forbidden in TCSTART.BTM ? Support 4
rfaquino TCMD 14.0 IDE Crash Support 7
epement differences in IDE/debugger between v12 and v14 Support 1
Alan Strader Take Command IDE/Debugger has stopped working Support 5
J Fixed IDE search keys don't work in TCMD 13.01.32 Support 3
vefatica IDE watch window Support 1
Stefano Piccardi IDE unexpectedly exits inside this batch file Support 17
newgeekorder Debugger IDE - strange tab and parameter behaviour Support 1

Similar threads