TreeExclude Not Honored

  • This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
#1
Hello everyone,

I seem to be having an issue with directories in my TreeExclude list showing up in my extended directory searches.

I've tried to simplify this as follows:

HTML:
TCC  11.00.43 x64   Windows 7 [Version 6.1.7600]
Copyright 2010  Rex Conn & JP Software Inc.  All Rights Reserved

C:\>mkdir Foo\Bar

C:\>dir foo

Volume in drive C is OSDisk         Serial number is 627b:874b
Directory of  C:\foo\*

3/11/2010  11:14a            .
3/11/2010  11:14a            ..
3/11/2010  11:14a            Bar
   0 bytes in 0 files and 3 dirs
   98,933,850,112 bytes free

C:\>*cdd /u
Indexing C:\
Indexing T:\

C:\>set TreeExclude=c:\Foo

C:\>echo %TreeExclude
c:\Foo

C:\>echo %@Option[FuzzyCD]
1

C:\>cd bar

C:\foo\bar>
I would expect that I could not cd in the subdirectory bar as c:\foo is in the exclude list.

Am I doing something wrong?

I appreciate the help.

Michael</dir></dir></dir>
 
#2
| I seem to be having an issue with directories in my TreeExclude list
| showing up in my extended directory searches.
| ...

| Am I doing something wrong?

Yes. You must set the TreeExclude before building the extended directory
search database, so that the undesired directories would never be in the
database.
--
HTH, Steve
 
#3
ah! I thought the exclude was handled during the search, not the build.
Ok, I'll check it out.

Thanks,

Michael


On Thu, Mar 11, 2010 at 11:33 AM, Steve Fábián <>wrote:


> | I seem to be having an issue with directories in my TreeExclude list
> | showing up in my extended directory searches.
> | ...
>
>
> | Am I doing something wrong?
>
> Yes. You must set the TreeExclude before building the extended directory
> search database, so that the undesired directories would never be in the
> database.
> --
> HTH, Steve
>
>
>