WAD Unusable state when using Chinese characters

Jul 17, 2020
I use Take Command v27, win 10, language and region setting is Chinese.
If there is a file name or directory name which contains Chinese characters, the characters are half width and Take Command will be an unusable state. In such state, the characters I input later will not show, leaving a blank line.

It seems a bug only in Take Command GUI interface. I tried to use tcc v27 in windows default cmd, it works well.
I also tried many settings in Take Command, such as toggle utf-8(it is default setting), change fonts, change chcp to 65001. Not work at all.
Maybe the console in take command itself didn't support CJK double width characters well.
Take Command (and TCC) do support Chinese DBCS double-wide character sets, but only if your code page is between 932 and 950. (Supporting it for other codepages slows everything down too much for the 99.999% of users who aren't using Chinese characters.)
Thank you for quick reply.
I have already use chcp 936, it is useful in tcc (No GUI version), but in take command, the font problem still exists.
I remember in v26, you published some bug fix to solve the problem. I will check it later, installing v26 to try again.

Similar threads