unwanted delay

#1
I am using TCC 21.00.39 x64.. It just suddenly started stalling for a about 15 seconds just prior to showing the > prompt when it opens a TCC window. Any idea on what could be causinging this on how to fix? I did not change the config.

When I tried to update to the lastest version it said an update was already in progress. I tried a reboot. No joy..
 
#2
I have a theory. It is working again spontaneously. I suspect it was checking with jpsoft.com to make sure my licence was valid, and it could not get through. The delay was the timeout. Ideally, TCC should check only once a day if it has not been getting through.
 

rconn

Administrator
Staff member
May 14, 2008
10,770
97
#4
If you're getting a (new) delay at startup, the IsLicense50.dll file probably got unregistered somehow. TCC will try to re-register it, but if you're not running in an elevated session Windows will discard the registration when TCC exits.

Try doing a "regsvr32.exe IsLicense50.dll" from an elevated session in the TCC installation directory.