1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

updater.exe fails with error message

Discussion in 'TCC/LE Support' started by efl74, Oct 13, 2011.

  1. efl74

    Joined:
    Jun 27, 2011
    Messages:
    2
    Likes Received:
    0
    Since around TCC/LE version 12.11, the updater is broken and displays a message that translates as "Specified path cannot be found" ("Le chemin d'accès spécifié est introuvable", since my system is in french). The problem still exits in TCC/LE 13.0.26.

    Looking in the updater.ini file, i've found an suspicious "/" character in the value of the DownloadsFolder field:
    DownloadsFolder=C:\Documents and Settings\USERACCOUNT\Application Data\JP Software\TCC/LE 12.11\updates\
    and
    DownloadsFolder=C:\Documents and Settings\USERACCOUNT\Application Data\JP Software\TCC/LE 13.0\updates\

    I've noticed that previous versions used a path like "C:\Documents and Settings\USERACCOUNT\Application Data\JP Software\TCC LE 12.0\updates" so i tryied removing the "/":
    DownloadsFolder=C:\Documents and Settings\USERACCOUNT\Application Data\JP Software\TCC LE 13.0\updates\

    This corrects the problem! (untill the next update will restore the faulty value in updater.ini as i tried 12.11.74 -> 12.11.76)

    I hope this will help someone else
     
  2. rconn

    rconn Administrator
    Staff Member

    Joined:
    May 14, 2008
    Messages:
    9,855
    Likes Received:
    83
    I don't know how you got that value in your updater.ini, but it's not in either the 12.11 TCC/LE or 13.0 TCC/LE updater.ini. Did you install into an old (maybe beta?) directory?

    Try removing that file, download the latest build, and reinstalling.
     
  3. lcg

    lcg

    Joined:
    Sep 14, 2011
    Messages:
    11
    Likes Received:
    0
    Ah, someone with the same problem I have/had, although on a German locale Windows 7.
    Good find, I never thought to check that file (in fact, I didn't know it existed). After using Process Monitor to track down the problem, my solution was to simply create the additional folder that the updater expects, i.e., "%APPDATA%\JP Software\TCC\LE 13.0\updates\". Now I have a folder "TCC" with a subfolder "LE 13.0", but it works. And, since this path does not change with the next update, it is a more permanent solution. ;)

    @rconn, when I stumbled upon this thread, I deleted the file and reinstalled TCC/LE 13.01.32; the installer recreated updater.ini with the same entries as efl74 mentions. I am using TCC/LE x64 on a German locale Windows 7 Professional SP1 (also x64, obviously). I had also never installed a beta version or anything before 13 before that, so it's not a remnant of a previous installation.

    HTH,
    lcg
     

Share This Page