Upgrade from b12 fails

  • This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
May 26, 2008
481
3
#1
I have TCMD 13.00.12 x64 installed right now. Attempted to upgrade to b16 using either OPTION /U or downloading/installing from FTP doesn't work.

The installer reports:

---------------------------
Take Command x64 13.0
---------------------------
There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor.
---------------------------
OK
---------------------------

Event viewer shows this:

Log Name: Application
Source: MsiInstaller
Date: 9/9/2011 10:26:40 AM
Event ID: 11722
Task Category: None
Level: Error
Keywords: Classic
User: TT\rod.savard
Computer: iwrl-l3adp5v.tt.local
Description:
Product: Take Command x64 13.0 -- Error 1722. There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor. Action ViewReg.exe_1, location: C:\WINDOWS\Installer\MSIBED2.tmp, command:
 

rconn

Administrator
Staff member
May 14, 2008
10,100
85
#3
Attempting to uninstall b12 results in the same/similar error message. Uninstall gets canceled.
(See all the previous messages on this topic.)

There is a bug in the x64 Windows Installer that causes build 12 uninstalls to fail when executing a custom script. (When you try to update to a newer build, Installer first runs the build 12 uninstaller.)

I added a workaround in build 13 & later, but the only way to get rid of build 12 is to go to the Registry and remove all references (and there are a lot!) to v13.
 
May 26, 2008
481
3
#4
Ugh. Does the Windows Installer CleanUp Utility work for this issue? I know MS no longer supports it or lets you download it, but I have it around here somewhere.....
 
May 26, 2008
481
3
#6
It worked. The Windows Installer CleanUp utility removed b12 from the MSI databases. Was able to install the latest build just fine after that.