v25.00.10 hangs when returning %_ipdnsserver

Nov 9, 2011
9
0
If I try to print the varible %_ipdnsserver TCC/TCMD hangs until I kill the process.

This simple script stops working as soon as I run it

@echo off
echo DNS is %_ipdnsserver
 
Nov 9, 2011
9
0
I have tried on two PCs, both running Windows 10 x64 Version 1809 Build 17763.678) - both are hanging when I try do do an

echo DNS is %_ipdnsserver

Ver 24 runs fine though.

Update 1: I just tried on one of the two PC's - it now seems to be running just fine (I am unable to test the other one at the moment). All morning I had the issues on both PC's and had to modify login scripts, but it runs fine on one of them now.

Update 2: Restarting TCC brought back the problem again unfortunately.

Update 3: I just installed v25 on a Microsoft Surface Pro 4 and the result is the same -- echo %_ipdns or %_ipdnsserver hangs TakeCommand

I have included a Log File from ProcessMonitor with the result from running "echo dns is %_ipdnsserver" in tcc, just in case it may help.
 

Attachments

Last edited:

rconn

Administrator
Staff member
May 14, 2008
11,910
133
I've tried on four systems on two networks and cannot reproduce this.

The only thing that changed between v24 and v25 was a minor update of ipworks16.dll (which is doing the query). Try temporarily renaming the ipworks16.dll in your v25 directory and copy the one from your v24 directory and see if that changes anything. (You'll need to do this from v24 because it'll be in use running v25.)

Anybody else seeing this?
 
Nov 9, 2011
9
0
I tried installing both v24 and v25 on a Windows 2012 Server - v24 works fine and v25 hangs.

Next I tried copying the ipworks16.dll into v25 but having the same hang-result when I query the %_ipdnsserver variable.

Update 1: If I start by opening a web page in TCC/TCMD (i.e. by typing "https :// jpsoft.com" (without spaces) and hitting enter), I can query the %_ipdns and %_ipdnsserver afterwards (but if I start a new TCC/TCMD I have to open a web page first in order to successfully query the variables).

Update 2: If I run "wmiquery a b" (which, of course, returns an error), it works afterwards as well.

I know - it makes no sense :)

Update 3: My solution for now is to place

set dummyValue=%@wmi[root\cimv2,"SELECT name FROM Win32_Processor"]

in top of my 4start.btm script - that allows me to query the variables.
 
Last edited:
Nov 9, 2011
9
0
"SCRIPT" outputs the following text but unfortunately still hands when echoing the variable.

JScript
XML
VBScript
VBScript.Encode
JScript.Compact
JScript
JScript.Encode
 

rps

Jul 6, 2008
426
5
I've tried on four systems on two networks and cannot reproduce this.

......................................

Anybody else seeing this?
No hangs using:

TCC 25.00.11 x64 Windows 10 [Version 10.0.18362.295]

Tried with multiple TCC tabs and standalone TCC.