view command not working

Aug 16, 2008
124
0
I just noticed that the view command is not working on my machine. To be precise, "view /h" and "view /w(indow)" do work but "view FILE" doesn't. No error, nothing. Same thing happens when I doubleclick the v executable. This happens with the latest TC 14 as well as 15 beta. V from the Prineas web site does work.

What can I do to debug this?
64-bit Take Command on Windows 8 64-bit
 
To be precise, "view /h" and "view /w(indow)" do work

I assume you mean "view /h FILE" and "view /w FILE"?

but "view FILE" doesn't

I can think of no reason why "view /h FILE" will work and "view FILE" will not work. Are you sure this is the case?

Are you perhaps using "v FILE" instead of "view FILE"?

Same thing happens when I doubleclick the v executable.

This is expected. You cannot run v.exe as a standalone app. It needs to be run by Take Command - either by using "VIEW" or by clicking the "V" button on the Explorer toolbar.
 
Aug 16, 2008
124
0
I assume you mean "view /h FILE" and "view /w FILE"?

I can think of no reason why "view /h FILE" will work and "view FILE" will not work. Are you sure this is the case?

Are you perhaps using "v FILE" instead of "view FILE"?

"view /h" just shows the help. "view /w" opens an explorer window to pick a file.

"view FILE" works in TC 14 but faiils without any hint on TC 15. I copied the v binaries from the old TC14 installation to the TC15 directory without any success. But the TC15 V binaries work with the TC14 installation. I begin to think that this is just another annoying licensing issue because I installed TC15 into the "old" TC14 directory.

On a VM I installed TC15 to C:... and there VIEW works. I copied the files to my D: drive and I get the message that the evaluation period has expired(!!!) - I installed the beta just yesterday for the first time; 30 days ago it wasn't even released.

Still I'd like to troubleshoot the issue...!
 
I copied the files to my D: drive and I get the message that the evaluation period has expired

VIEW will not run without a valid TC15 license. Can you run Take Command? What does the TC About box display?

Still I'd like to troubleshoot the issue

There should be a file called V.log in one of the following directories:

C:\Users\UserName\AppData\Roaming\V or C:\Users\UserName\AppData\Local\V

It will contain an error line if VIEW cannot obtain a valid license.
 
Aug 16, 2008
124
0
Ah, bingo, I ran a Process Monitor log and saw that V was logging to V.log. Let's see what we got here:

"Windows Version 6.1 (Build 7601), Platform = 2
Version 14.90.3 TC (Beta 3) (x64)
Command Line: v /tcmd:15 tcstart.btm

11-03-13 13:05:38 (531260718): Take Command CU not licensed: m_nStage=109, stage=2, User Name: Thorsten Kampe
11-03-13 13:05:38 (531260734): Take Command not licensed - no user name found: m_nStage=109, stage=2"

Niiiiiiiiice...!

I just wasted hours of my life troubleshooting another stupid license issue. I guess my decision to migrate from Tcmd to ConEmu on the weekend was justified. If I troubleshoot issues with ConEmu I'm troubleshooting /real/ issues, not issues that are artificially imposed onto the innocent user to combat "license issues".

Thorsten, who is really pissed off
 
Oct 29, 2008
88
0
I had this same problem after entering my registration information as an administrative user. Try entering your license key again as the regular user. Unfortunately, this means entering it under each user you want to use.

ref: VIEW doesn't work again
 
Similar threads
Thread starter Title Forum Replies Date
T VIEW only works from command line Support 14
Joe Caverly Why does TCCRT return VIEW as an internal command? Support 6
E Fixed View command broken in version 21.0 build 22 Support 9
E View (internal command) does nothing now Support 3
M Sync folder/list view with command window? Support 2
A How to? Invoke View Clipboard from command line Support 8
Joe Caverly Display the VIEW window in a Take Command tab window Support 2
vefatica VIEW ... remember the UTF-8 setting? Support 0
Alpengreis Documentation Minor issue in help file for view /E Support 1
vefatica VIEW wrap searches? Support 2
R Documentation Help Nit > bdebugger View Menu Support 0
Joe Caverly Pipe into VIEW and search Support 12
vefatica VIEW ... CommandPrompt ... TC21 ... unregistered Support 6
vefatica Start VIEW with the toolbar showing? Support 5
rps How to? Piping to View /gb Support 1
vefatica VIEW ... remember no toolbar Support 0
vefatica File Explorer ... remember view settings? Support 5
vefatica "View" settings still not remembered Support 10
vefatica TCMD ... remember View settings? Support 7
C View Print Wrap - please break at whitespace Support 3
C VIEW PRINT /Wrap doesn't work Support 0
C VIEW PRINT - Documentation corrected - Font size Support 8
C WAD VIEW print multiple files - switches fail Support 10
MickeyF TCC v16 crashes when I hit F1 to view help Support 9
R V19 - 'V' and 'View" Support 6
cgunhouse Crash on View/Folder Support 1
M View doesn't recognize Ctrl+End and Ctrl+Pos1 Support 2
vefatica Speaking of VIEW Support 18
nikbackm VIEW broken in v18 + Windows 10 Support 8
Alpengreis [Bug?] View (V) Prefs Error (TC 18.00.27 x64) Support 4
D Fixed Cut and paste in TC's file/folder view does not remove file Support 17
vefatica VIEW and chars in 128-255 Support 4
MickeyF where to view the latest JPSoft newsletter? Support 0
Joe Caverly VIEW window in a TCC tab window problems Support 5
vefatica Fixed No text in List View! Support 4
D Folder/List view changed in v15 Support 8
D How to? V15.00.30 -(help!) - Floating view windows don't open Support 1
nikbackm Fixed v15: VIEW - encoding and CSV issues Support 9
S TCMD No List-View with Libraries? Support 5
C Fixed Starting editor from VIEW Support 9
J VIEW doesn't work again Support 16
S Fixed View and V do not work in new 13.04.52 x64 installation Support 11
jwblyth How to? Help will not Load in View (File Viewer)?? Support 4
M Folder View Freezing Support 10
Frank is the search-function in VIEW working? Support 2
H VIEW not "screen reader friendly: Support 7
J VIEW crash on redirected input and numbered bookmarks Support 6
gschizas View uses Windows-1252 codepage instead of System codepage Support 4
D view in tab and focus follows mouse Support 10
D View Help Keyboard Support 1

Similar threads