Way off topic

  • This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
On my home computer many apps (MS Photo Viewer, a Nikon (camera) utility, MSPaint, Adobe Acrobat, and DevStudio, to name a few) can print to the Microsoft XPS Document Writer and many apps (Excel, Winword, Outlook, IE, Notepad, and FireFox, to name a few) cannot (they give a variety of error messages and some just fail silently). The XPS Document Writer cannot print its own test page.

By comparing registry entries with those on my work computer, where the XPS Doc Writer works fine, I discovered that the XPS Writer was changed (at home) at exactly the time I installed IE11, which required KB2670838, which messed with the XPS Writer.

I thought I had the problem nailed so I uninstalled IE11 and KB2670838. ... nothing changed!
I have uninstalled/reinstalled the XPS Document Writer itself several times.

So I'm back to square one, needing ideas. ... any ideas?
Jun 2, 2008
Just throwing out some ideas.. since I've rarely used it, but mine can print/save its own test page.

Windows 7, I take it?

Maybe the driver files themselves are corrupted.

I'm sure you removed the device from Devices and Printers, but did you remove the driver too? Use Print Management in Administrative Tools. I don't know what the difference between Remove Driver Package and Delete is, but the former sounds more thorough and always works for me.

If you didn't remove the driver, when you reinstalled it, did you tell it to replace the existing driver?

Perhaps there's something stuck in "C:\Windows\System32\spool\PRINTERS", although I don't know why that would affect some programs and not others. Note that that folder can have some tricky permissions on it. I can get in there with Explorer, but TCC/LE gives me a "TCC: (Sys) The system cannot find the file specified. "PRINTERS"" and CMD says "Access is denied." :-/
I just used ControlPanel\ProgramsAndFeatures to remove/replace the Windows feature. If I remove the driver, how do I get it back?

There's nothing stuck in the spool.
Interesting ... from Print Management, I can print the test page; from Devices and Printers I cannot. On second thought, that's no surprise. All apps can print to it when elevated (and Print Management is probably elevated). But I have scrutinized it's security, and "everyone" (as well as me, "vefatica", by name) has permission to use it.
Jun 2, 2008
I just used ControlPanel\ProgramsAndFeatures to remove/replace the Windows feature. If I remove the driver, how do I get it back?
Oh.. hmm... Well, I would think(hope?) it would get pulled from the same place other things that weren't installed to begin with would come from.

When you remove it that way, does the driver get removed also?

Interesting about the elevation... On mine, Everyone has just Print, CREATOR OWNER has Manage documents, and Administrators has all 3.

Btw, the fact that I'm an administrator and I have UAC disabled might be keeping me from seeing what the rest of the world sees.
Jun 2, 2008
Interesting... I just figured I had KB2670838 since Windows Update says I'm all up to date (and I haven't hidden it either), but I decided to check my system for it anyway and I see no trace of it. This discussion mentions it was a prerequisite for IE10, which I did have until installing IE11, so... :-/


This thread is interesting too...


I'm thinking I'm GLAD I don't have it...

Eeeww.. none of these results are very comforting!

I'm an admin. If UAC were disabled, I suspect I'd have no problem.
I didn't test disabling UAC but I enabled the built-in administrator account and logged in as administrator ... and everything worked. As far as I can tell, the XPS Writer has EXACTLY the same set of permissions as my physical printer, which works in all circumstances.
Problem Solved! This is what I wrote in a TechNet thread where I was hoping for some help.
Problem solved!

Apparently, the XPS Writer needs delete permission in %TEMP%.

Before: "authenticated users" could do anything except delete in %TEMP% ... "users" somewhat less ... "system" and "administrators" had full control.

I am "vefatica", an administrator running with a UAC-crippled token. Apparently, for some apps that was not enough. I'd like to know more about the differences between those apps which could use the XPS Writer and those which couldn't. As (crippled) "vefatica", I can manually delete things in %TEMP% with no hassle.

When I specifically added "vefatica" with full control over %TEMP%, all the XPS printing problems went away.
Jun 2, 2008
Ah.. I'm glad you figured it out!

I wonder how that happened, though..? KB2670838 maybe? My %temp% is "C:\Users\<username>\AppData\Local\Temp", which has only inherited permissions that consist of full control for SYSTEM, me, and Administrators, and that inheritance for each comes from clear up at "C:\Users\<username>\".
My %TEMP% is h:\temp, owned by S-1-5-21-3291446647-2681218026-3195555329-1005. That's not a user of this system. Almost certainly; h:\temp has some left-over security settings from my previous version of Windows. The more interesting question is why is this (the XPS Doc Writer) the ONLY problem with %TEMP% and why does it affect ONLY some apps? I monitored %TEMP% and discovered that the XPS Writer ALWAYS creates/deletes in %TEMP%. But some apps could use it and some couldn't. ...?

TEA-Time, who owns your temp directory (Properties\Security\Advanced\Owner)?
On my work computer, where XPS has always worked, %TEMP% is also owned by a relic of an older Windows. But there, "vefatica" (by name) had been given full control over %TEMP%. That could have been done manually, by me, at some time in the past and for a reason that escapes me now.
Is KB2670838 on that computer too?
No. But I re-installed KB2670838 on this one (no harm) because it had an effect I like. Namely, after KB2670838 the FontCache service runs in the "LocalService" services group, in the same instance of svchost.exe as several other services. Before KB2670838 FontCache ran (all alone) in the "LocalServiceAndNoImpersonation" group, thus needing its own instance of svchost.exe. IMHO, the fewer processes the better. My machine idles at 28 processes (which includes an SMTP server, two email clients, and PowerPro)