Why doesn't my python program get executed without specifying its path?

Jun 3, 2008
115
1
Temecula, CA
I've got a python program, pycky.py, that resides in a directory that's on the system path. I also have PATHEXT set to include the .py extension. Yet if I just enter pycky or pycky.py, it says unknown command. If I give its path, e.g. ..\apps\pycky (or include the .py extension), it runs.

-> set path
C:\Program Files\Python27\;C:\Program Files\Python27\Scripts;C:\Program Files\Python27\Tools\Scripts\;C:\WIP\dvp\tools\python;C:\WIP\dvp\tools\python\ppl;C:\Program Files\Python27\apps; ... (rest of path snipped)

-> set pathext
.COM;.EXE;.BTM;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH;.MSC;.PY

-> assoc .py
.py=Python.File

-> ftype python.file
python.file="C:\Program Files\Python27\python.exe" "%1" %*


Oh, I should add that when I run Option, the GUI tells me that PathExt is checked. However, when I checked its value directly from the command line (option pathext), it said pathext=No. ??? Well, I changed it via command line: option //pathext=Yes. Now it says pathext=Yes. However, it still doesn't run my python program.

So I have two confusions here. First is - why doesn't the python program run? And second, what's up with the option from the command line versus from the GUI?
 

samintz

Scott Mintz
May 20, 2008
1,488
15
Solon, OH, USA
Are you running Option from the TCC command line or from within TCMD? If you run it from TCMD, it will impact the next launched instance. If you run it from the command line, it will impact the current instance (and the next).
 
Jun 3, 2008
115
1
Temecula, CA
Are you running Option from the TCC command line or from within TCMD? If you run it from TCMD, it will impact the next launched instance. If you run it from the command line, it will impact the current instance (and the next).

Everything is from the TCC command line. I rarely ever even use tcmd.

BTW, I forgot to tell you version info:

TCC 16.03.55 x64 Windows 7 [Version 6.1.7601]
TCC Build 55 Windows 7 Build 7601 Service Pack 1
 
Similar threads
Thread starter Title Forum Replies Date
vefatica Setting array variable ignores leading spaces (and @execarray doesn't) Support 4
gworley Virtual network drive filename completion doesn’t get directories Support 0
vefatica Win10's ANSI doesn't like 2>NUL Support 10
vefatica Win10, alternative screen buffer, cursor doesn't blink Support 11
M Trying to use ffind with a @file.lst doesn't work Support 4
Charles Dye Ctrl-Shift-Up doesn't update directory history Support 1
gschizas Take Command (Environment) doesn't show v2 ANSI colors Support 30
vefatica Fixed JOBS /K doesn't work Support 2
E Fixed SHRALIAS doesn't work / SHRALIAS.EXE is missing in v20.11.35 Support 2
D WAD Reboot doesn't shutdown or restart Support 13
M Documentation Q.Search doesn't support selection? Support 1
R Fixed 7ZIP Compression Method Option Doesn't Work Support 1
T Regex engine doesn't recognize native DOS line endings Support 2
E Fixed DEDUPE doesn't handle filenames with whitespace properly when symlinking Support 1
D Docking doesn't persist Support 5
E WAD DESCRIBE under TCC 19 doesn't work with diacritics Support 14
C VIEW PRINT /Wrap doesn't work Support 0
D CD doesn't always find everything Support 8
M View doesn't recognize Ctrl+End and Ctrl+Pos1 Support 2
M Ctrl-End doesn't work. DelToEnd is not executed Support 13
B Fixed FFIND doesn't find last character in file without CR/LF at EOF Support 1
G .BTM association doesn't work anymore Support 1
jadaml Documentation Is COPY realy doesn't work for any HTTP and FTP? Support 3
D do /s doesn't recurse Support 1
D WAD Alt-Left doesn't work, but Alt-Shift-Left does Support 1
I How to? Bat Works but BTM Doesn't Support 6
B %@lines doesn't count last line without cr/lf at eof Support 1
williamleara WAD ribbon doesn't remember expand/collapse setting Support 3
vefatica Why doesn't "IDE %_ININAME" work? Support 4
M How to? /Elevated doesn't do it for me... Support 8
D Why doesn't ffind find directory? Support 3
Phileosophos TPIPE doesn't work at all with v16 Support 3
D ejectmedia doesn't work in v16 Support 2
Phileosophos Fixed Register for all users doesn't register for all users Support 10
T "Checking for a newer version" doesn't complete Support 18
vefatica Doesn't IDE auto-indent? Support 3
C FFind /w works but FFind /= doesn't? Support 2
noahcoad WAD cmd.exe under tcc doesn't find apps Support 4
vefatica Fixed TPIPE doesn't /SPLIT at characters Support 0
M Site doesn't recognise cookies Support 0
D What's New doesn't mention copydir movedir Support 25
D TIMER OFF doesn't work Support 21
M @Files sure doesn't work the way I would have assumed it did! Support 4
M Why doesn't this @Field function work? Support 0
M Why doesn't this work? Support 12
vefatica ON BREAK doesn't always work Support 23
K_Meinhard Fixed ? TCMD 14.02 doesn't start here Support 4
Stefano Piccardi 14.01.33 unset doesn't complain about undefined variables Support 8
J VIEW doesn't work again Support 16
samintz Fixed CASEALL doesn't work Support 1

Similar threads