Why won't my changes to Options take?

#1
I really, really need to be able to change to a directory using a wildcard. I do it in cmd.exe all the time. So, I read up on it and it appears I need to configure the "extended directory search" under Options/Command Line. I did that, three times, and, each time, when I go back to it, nothing's changed. What's up with this? Why can't I do simple "extended directory searches?"

I also want to be able to insert on the command line. I'm tired of re-typing long instructions. Again, in that Options configuration, I chose that, but, nothing takes.

Thanks.
 

rconn

Administrator
Staff member
May 14, 2008
10,551
97
#2
Are you using the OPTION command in TCC (which will modify the TCMD.INI for the current TCC session), or the "Options / TCC" configuration dialog in TCMD (which will only affect *new* sessions, not the current one)?

When you run OPTION, it will display (on the title bar) the name of the TCMD.INI that it's modifying. Make sure you didn't put it in some place where you don't have write permissions (like anything under "program files", the root directory, etc.).
 
#3
Yes, I'm using the Option tab in TCC. I'm a full administrator on this server, so, I don't think permissions would be an issue. Even if that was the case, why won't it just tell me that then?

Although, now that I look at it again, I see at the top that it's pointing to C:\ProgramData\JPSoftware\Take Command x64 19.0\tmcd.ini. And, that's NOT where I have TCC installed. I have it installed on my E: drive. So, how can I change that?
 
#4
OK. I got it to stick now. I just went into that directory structure, c:\programdata, and gave my user permissions to write to the JPSoft directory. So, my choices are now live. But, why can't I change to a directory now with a wildcard? I type "cd 00306*" and it tells me it can't find it. And, there's a directory in there called 00306-claro-smms-iasb.

I chose "search level 2" in the config.

Thanks.
 

rconn

Administrator
Staff member
May 14, 2008
10,551
97
#5
OK. I got it to stick now. I just went into that directory structure, c:\programdata, and gave my user permissions to write to the JPSoft directory. So, my choices are now live. But, why can't I change to a directory now with a wildcard? I type "cd 00306*" and it tells me it can't find it. And, there's a directory in there called 00306-claro-smms-iasb.

I chose "search level 2" in the config.

Thanks.
First, you have to select what kind of fuzzy directory searching you want (i.e., with Everything Search or with jpstree.idx). Then you have to create the index (using Everything or using CDD /S. Once the indexes are created, they will be updated automatically when you create or delete directories.
 

rconn

Administrator
Staff member
May 14, 2008
10,551
97
#6
Yes, I'm using the Option tab in TCC. I'm a full administrator on this server, so, I don't think permissions would be an issue. Even if that was the case, why won't it just tell me that then?
If there is a permissions / policy issue, Windows caches the write (and then discards it) and doesn't return an error to TCC.

If you are running in an elevated session, it should force the write.