By registering with us, you'll be able to discuss, share and private message with other members of our community.

SignUp Now!

Windows 11 installer: Default Start menu entry just runs tcc.exe, not tcmd.exe, and only the shell window appears - no menus or GUI interface

Greetings, and thanks!

I must say, the issue I note in the title stymied me for a while. I just purchased Take Command and installed it. I had my registration info copied onto the clipboard, ready to register and run the app, and the first thing I tried to do after running the app was to enter my registration info to register my paid software. I looked everywhere in the interface, which looked like the first attachment ("tcc-only.jpg") but I could find no possible way to enter the registration info. The "About" entry didn't work, the "Settings" didn't work - nothing.

So I looked at the registration confirmation email very carefully and it said "To register Take Command, click on the Help menu entry, click on "Register", and enter the key provided at the top of this message." However, try as I might, I could not find any menus at all, let alone a "Help" menu entry.

I was super confused before some little bell went off and I navigated to the "C:\Program Files\JPSoft\TCMD32" folder, in which I saw many EXEs (second attachment, "many-exes.jpg"). I then took a guess and double-clicked on the "tcmd.exe" and - lo and behold - I was prompted to enter my registration information (which I did) AND when that was successful - the actual Take Command application (that I see on the website, with a top section and a menu bar in addition to the command window) appeared. (See third attachment - "the-actual-expected-app.jpg".)

It then became clear that the problem must be the shortcut that appears in the Windows 11 "Start" menu (i.e., press the Windows key, then in the Start menu just start typing "Take Command", then only one entry appears (called Take Command - see fourth attachment, "the-start-menu-entry.jpg")) - that this shortcut actually points to the wrong app!

And this is true. If you right-click on the "Take Command" entry in the Start menu and click "Open File Location", then right-click on THAT entry and go to "Properties", you find THIS value for the TARGET:

"C:\Program Files\JPSoft\TCMD32\tcc.exe"

Ugh! That's the wrong app! But this is what appeared when I first tried to run Take Command after purchasing, downloading and installing it.

So I simply changed this to:

"C:\Program Files\JPSoft\TCMD32\tcmd.exe"

...and the Start menu item now works - you run the app, and the expected app (with the top section/menu bar) appears.

I thought I would submit this ticket to let you know about the problem. Somebody not quite as skilled as myself, I suspect, would be utterly and extraordinarily confused about what is going on when it is impossible to register their app and when what you see when you run Take Command that you've just purchased looks nothing like what you see discussed on the website (i.e., no top section - no menus - just the command section).

Hopefully, with this ticket in hand, you can figure out the glitch and save others in the future from the same head-scratching confusion I have just gone through.

Dan N


  • tcc-only.jpg
    22.8 KB · Views: 5
  • many-exes.png
    131.1 KB · Views: 5
  • the-actual-expected-app.png
    32 KB · Views: 6
  • the-start-menu-entry.png
    311.4 KB · Views: 5
I just updated to Take Command v32.00.15 and double-checked the Start menu shortcuts. The installer created shortcuts to both TCMD.EXE and TCC.EXE.

The way the Windows 11 Start menu displays them is pretty confusing, though. The installer creates a "TCMD32" folder and puts both shortcuts inside it. The Windows 11 Start menu, however, shows the "Take Command v32" shortcut as if it were outside the "TCMD32" folder, but the "TCC 32" shortcut is shown inside the folder. Those silly Microsoft programmers must've been smoking some wacky weed.

Daniel, are you running Windows 11?
The Take Command installer creates shortcuts for both Take Command and TCC. You can enter your registration info in either -- if you're running TCC, run OPTION from the command line and click on the "Register" tab.

The Take Command installer does not create a TCC shortcut in the Start Menu. However, if you install the stand-alone version of TCC, you will get a TCC shortcut there.
I am running Windows 11. It would be useful to see the shortcut for the actual application "Take Command" when you type "Take Command" in the Start menu - rather than the shortcut for "TCC" labeled as "Take Command".

In other words, if I type "Take Command" and I see an icon called "Take Command" appear, I do expect that when I click on it, it will indeed be the application "Take Command" that runs - not TCC. I would expect the icon for TCC to be named "TCC".


Similar threads