Declined wish-list: add a command to copy a file to clipboard.

May 20, 2009
I would like to be able to copy a file to the clipboard, so that after this command I can right into a folder and do a paste, and the file is there.

Thank You and regards

Rodolfo Giovanninetti
TODROP, in 4Utils. But my copy doesn't want to load in Take Command >= 21.0. Vincent, do you have newer versions available somewhere?
Yes, TODROP does that. The 4UTILS on works OK here. Do you have the necessary ONIG dll? It's also on the ftp site and part of older TCC installs.
I never used plugins, and I do not understand how to use them.
I downloaded the files "" and "" and expanded them into "C:\Program Files\JPSoft\TCMD24\PLUGINS".
But, when I start TCC, I get the errors that I report below.

Thank You and regards

Rodolfo Giovanninetti

TCC: (Sys) The specified module could not be found.
 "C:\Program Files\JPSoft\TCMD24\PlugIns\4utils64.dll"
TCC: (Sys) The specified procedure could not be found.

TCC  24.02.48 x64   Windows 10 [Version 10.0.17763.379]
Copyright 2019 JP Software Inc.  All Rights Reserved
Registered to FARMILA-007

[C:\Program Files\JPSoft\TCMD24]cd PLUGINS\

[C:\Program Files\JPSoft\TCMD24\PLUGINS]*dir

 Volume in drive C is unlabeled    Serial number is d034:9712
 Directory of  C:\Program Files\JPSoft\TCMD24\PLUGINS\*

04/04/2019  18:01         <DIR>    .
04/04/2019  18:01         <DIR>    ..
30/08/2018  21:48          22.016  4utils.txt
30/08/2018  21:48             118  4utils64.dat
30/08/2018  21:46         148.992  4utils64.dll
24/01/2017  23:48         708.608  Onig.dll
             879.734 bytes in 4 files and 2 dirs    888.832 bytes allocated
      74.372.423.680 bytes free
I moved the file "Onig.dll" from "C:\Program Files\JPSoft\TCMD24\PLUGINS" to "C:\Program Files\JPSoft\TCMD24", but still I get the first error.

Thank You and regards

Rodolfo Giovanninetti
I will try it, thank You.
I have also an OLD test system with Windows 2003 32 and TCC 16.03.55, is there is a version of Your ToDrop tool for that?

Thank You and regards

Rodolfo Giovanninetti
I can't support old ones. But here (attached) is the one from my v16 install on Win 7/32.


    92.7 KB · Views: 222
Thank You for the file, but on 2003 I still get an error.
TCC: (Sys) The specified procedure could not be found.
I looked for 4utils in internet, and I found a version that works with 2003 and TCC 16 ("Version: 6.6 Build 14"), but it has not Your ToDrop.
Do You remember if there was a version that worked with TCC 16 and that had ToDrop?

Thank You and regards

Rodolfo Giovanninetti
What's "Version: 6.6 Build 14"?

I use this.
v:\> ver

TCC  16.03.55   Windows 7 [Version 6.1.7601]

v:\> todrop /?
TODROP /C(lear) | [/A(ppend)] file [file ...] - files to clipboard as CF_HDROP

If it requires a Win7 function that doesn't exist on Win2003, I haven't got a clue!
It is text that I got from Your plugin, at least I believed so.
I copy below the screen-shot.

Thank You and regards

Rodolfo Giovanninetti


Similar threads