XenForo styles

Jan 19, 2011
573
8
Norman, OK
#2
I use an extension in Chrome called "Stylish". It is used override the CSS styles of any page. You could probably use GreaseMonkey or something similar also.
 
#3
Thamks but I do not have Chrome. I am afraid of the six-valent form of chromium, it's poisonous. In Firefox (build 29) indicates that it is "all or nothing", cam't make cjanges for just a single website.
 
Jun 2, 2008
295
1
#7
Holding the Ctrl key down and scrolling the mouse wheel also zooms in and out.

Perhaps there's a problem with your browser's cookies. Maybe clear them out?
 
Jan 19, 2011
573
8
Norman, OK
#8
In Firefox (build 29) indicates that it is "all or nothing"
I have Firefox 29. I installed the Stylish addon and it works just like in Chrome (even with the Erin Brockovich reference.) You can have site specific modifications.
Screenshot - 5_1_2014 , 14_19_22.png
 
#9
I tried just increasing the (default) font size. Makes it easier to read, but also reduces too much the "code" block.

I installed the "stylish" Firefox add-on, but I would appreciate detail instruction how to activate it only in XenForo.
 
#10
You said you liked Times New Roman font so, here you go...
  1. Click Stylish button
  2. Click "Write new style"
  3. Click "Blank style..."
  4. In the "Name" field type JPSoft Forum
  5. In the code box below the "Insert" button, paste the following...
    HTML:
    @-moz-document url-prefix("http://jpsoft.com/forums/") {
    
        .messageText { 
            font-family: "Times New Roman";
            font-size: 1.5em;
            color: black;
        }
        .bbCodeBlock pre, .bbCodeBlock .code {
            font-size: .68em;  /* 10pt default =~ .68em (I prefer em sizing) */
        }
    
    }
  6. Edit as desired
  7. Click the save button
Edit: Added code block sizing.
 
Last edited:
#11
Appreciated. There is just one thing I can't find: the Stylsh button. This morning - I hope it was unrelated - I had temporary Internet access rate in telephone modem range (under 100 kb/s) and I turned things off and on. This effected both my Win7 and my WinXP. Sometimes a Stylish thanks for installing tab was the first one, not now.
 
#12
Under the Firefox "Tools" menu, select "Add-ons" (or you can just type CTRL-SHIFT-A). The "Extensions" tab (on the left) will let you see if you have disabled Stylish and enable it again. If it is enabled, you can also create/edit/disable your styles from the "User Styles" tab (on the left) on the same Add-ons Manager page.
 
#16
I am using Georgia for writing this post, and it would be perfectly good if it were default. How do you do that? Note: the actual post is now TNR, but what I type (which I have difficulty with) is sans serif with very narrow i,l, etc. I think Arial, but I have not discovered how I can interrogate XenForo what it is.
Thanks for every ones' patience!
 

Charles Dye

Super Moderator
Staff member
May 20, 2008
3,556
46
Albuquerque, NM
prospero.unm.edu
#17
I've never messed with it much, but it appears that the forum style (down in the lower left corner, just above "Forum software by XenForo") affects the default typeface for drafts. If I change it to "BP-White", new posts default to some sans face -- Arial? Tahoma? When it's set to "Default Style", new posts default to (I think) Georgia.

Hunh. And it also affects existing posts for which no font was specifically set. If I change the forum style to "BP-White", then my post above, which I claim is in Georgia, appears in the sans instead.
 
#20
Are you still using Stylish? If so...
HTML:
@-moz-document url-prefix("http://jpsoft.com/forums/") {
  .messageText {
    font-family: "Times New Roman";
    font-size: 1.5em;
    color: black;
  }
  .bbCodeBlock pre, .bbCodeBlock .code {
    font-size: .68em; /* 10pt default =~ .68em (I prefer em sizing) */
  }
  .navTabs .navTab.selected .tabLinks a {
    color: black;
    font-size: 1.5em;
  }
}