1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

z_newmove.btm questions

Discussion in 'Support' started by Charles G, Dec 30, 2013.

  1. Charles G

    Joined:
    Apr 2, 2011
    Messages:
    1,027
    Likes Received:
    0
    using the attached z_newmove.btm I am still getting prompted for a replace - which I am trying to advoid. I don't want to use setdos /x at all.

    Code:
    C:\z_Dothis\Z_NewAll\WAV_002\^ELVIS~41.WAV ->! C:\Z_NewAll\0001_WAV\^ELVIS~41.WAV (Replace) (Y/N/A/R)?
    
    Any ideas why this is occurring?

    I have attached the BTM and the jpsoft.ini - with the passwords [omitted] ....
     

    Attached Files:

  2. vefatica

    Joined:
    May 20, 2008
    Messages:
    7,971
    Likes Received:
    30
    I didn't try it but I suppose it's because you're using "/R". The help for MOVE says:

    /R Prompt for a Y or N response before overwriting an existing destination file
     
  3. Charles G

    Joined:
    Apr 2, 2011
    Messages:
    1,027
    Likes Received:
    0
    I know what the /R does on the MOVE but I am trying to get the if not isfile ... to work - given the strange file name from the new text txt file...
     
  4. vefatica

    Joined:
    May 20, 2008
    Messages:
    7,971
    Likes Received:
    30
    But you said
    That seemed to be your only complaint.
     
  5. vefatica

    Joined:
    May 20, 2008
    Messages:
    7,971
    Likes Received:
    30
    Anyway, your unprotected '^' is getting discarded. Double it.
    Code:
    v:\test> touch /c ^^elvis~41.wav
    2013-12-30 20:23:09.773  V:\test\^elvis~41.wav
    
    v:\test> d *.wav
    2013-12-30  20:23  0  ^elvis~41.wav
    
    v:\test> if isfile ^elvis~41.wav (echo isfile) else (echo notfile)
    notfile
    
    v:\test> if isfile ^^elvis~41.wav (echo isfile) else (echo notfile)
    isfile
     
  6. vefatica

    Joined:
    May 20, 2008
    Messages:
    7,971
    Likes Received:
    30
    '^' in a filename is very unfortunate. Without SETDOS I think you'll need to jump through some hoops. One strategy would be to rename everything in both the source and target directories to get rid of the carets and put them back when your done (maybe others have better ideas). If there's a character you're sure won't be in any filenames (I used the "cent" symbol) you might ...
    Code:
    v:\test> d *.wav
    2013-12-30  20:39  0  ^elvis~41.wav
    2013-12-30  20:52  0  ^presley~41.wav
    
    v:\test> do f in * /a:-d ( ren /q "%f" "%@replace[^^,%@char[162],%f]" )
    
    v:\test> d *.wav
    2013-12-30  20:39  0  ¢elvis~41.wav
    2013-12-30  20:52  0  ¢presley~41.wav
    
    v:\test> do f in * /a:-d ( ren /q "%f" "%@replace[%@char[162],^^,%f]" )
    
    v:\test> d *.wav
    2013-12-30  20:39  0  ^elvis~41.wav
    2013-12-30  20:52  0  ^presley~41.wav
     
  7. Charles G

    Joined:
    Apr 2, 2011
    Messages:
    1,027
    Likes Received:
    0
    Would maybe an update to the FixNames.dll be a good option?
     

Share This Page