1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Custom colors not saved in TCC 14 / Windows 7 x64

Discussion in 'Support' started by wingo395, Jul 12, 2012.

  1. wingo395

    wingo395

    Messages:
    10
    This has worked on all previous versions of Windows. I have Windows 7 x64 and TCMD 14.00.29.

    I usually set colors for my shells windows via the TCC Properties in the window's titlebar button in the upper left corner. I set my RGB background to 0/0/64. Windows used to ask if I wanted to save it just for that window, or all future windows, so I select all windows, and the data would be stored in the TCC.lnk file. I noticed in Win7 that there is an add'l menu entry, "Default".

    When I close the window and reopen it, the background is back to black. The custom color entry for Blue (64) on the Default menu tab is saved, but on the Properties menu, it is set back to 0.

    I don't really want to use the Windows default Blue value (0/0/255).. is there a way to truly save the color settings? What's odd is that the other settings are saved - font, font size, window size and position...

    Thank you!
    Gary
  2. vefatica

    vefatica

    Messages:
    5,125
    Could the settings in TCC's OPTION\Windows dialog be getting in the way? I am always careful to set fore/back the same in both places.
  3. Frank

    Frank

    Messages:
    258
    I have 2 entries in my tcmd.ini (likewise since 4dos.ini I think):

    InputColors=Bright Green on Blue
    StdColors=Bright Yellow on Blue
  4. Charles Dye

    Charles Dye Super Moderator Staff Member

    Messages:
    2,599
    TCC sets its own console palette. In the OPTION dialog, select the "Windows" tab, then the "Console Palette" button. Sorry, I can't give you detailed instructions; I haven't messed with it much myself. But I think what you want to do is create a "Custom Color"...?
  5. wingo395

    wingo395

    Messages:
    10
    Charles, thanks!! Bingo.. I had never seen that Console Palette button before. I changed Black from 0/0/0 to 0/0/64 and now all is good. Thanks! Now, onto the next issue (Win7 UAC :)
    Gary

Share This Page