Brain Dead?

#1
I just had to re-install TCMD 18 after getting a new hard drive installed.

I cannot for the life of me get the colors right in TCMD. TCC is fine. But the background on TCMD is bright blue instead of dark blue. I have tried everything -- I know, everyuthing but the right thing.

How do I set the background on TCMD?

Chuck Billow
 
#4
It's no problem here because I generally don't use TCMD. But I don't understand how it works. All my consoles (TCC, CMD, PS) are white on black with a bright green prompt (and TCC has bright yellow input). TCMD is set to use black on white. It I run TCC in a new tab I get the console colors ritht from the start.

1520534863010.png

If I run CMD in a new tab, I see

1520535088144.png

If I run Powershell in a new tab, I see

1520535274895.png
 
#11
The bottom line seems to be that, if you want TCMD to look differently from TCC, you'll have to do (more or less) monkeying around, perhaps with "IFF %_TAB == 1 THEN ..." in TCSTART. And note that TCMD knows beans about ANSI escape sequences; it just passes them on to TCC.

Indeed, if you're not using non-default colors,
Code:
CLS /C <TCMD's colors>
seems to make things OK.
 
#12
Actually, I want TCMD to look exactly like TCC. I set the colors there (bright white on (dark) blue) and it run exact;ly that way.

I was always able to just port over TCMD.ini and move on from there.

I tried uninstalling and reinstalling, but it made no difference. I get the bright white letters fine, but on a bright blue background. I just don't understand why, if I am installing the same version software, same video hardware, that this is there. Never happened before...

Oh well, back to black.
 
#14
OK< now I KNOW I'm getting old. After all the tinkering, I had given up, and set my TCMD window to bright white on black. Till a moment ago when I opened it, and now it's the bright white on BLUE -- not BRIGHT blue, but regulation "dark blue."

I guess it figured it had screwed with my head enough, and put it back the way it was.

Sigh...
 

Charles Dye

Super Moderator
Staff member
May 20, 2008
3,504
46
Albuquerque, NM
prospero.unm.edu
#15
I've been messing with the palette dialog, and I'm not finding it very intuitive. Looks like it writes your changes to the .INI file, but only if you press "Add to custom colors" before OK. If you don't press "Add to custom colors" then OK just closes the dialog. And if you do everything right, then your changes won't take effect until you restart Take Command.

It almost seems easier to edit the .INI file by hand. I've discovered that, although TCMD writes those values to the file as decimal, you can instead use hex with a leading 0x.
 
#17
I've been messing with the palette dialog, and I'm not finding it very intuitive. Looks like it writes your changes to the .INI file, but only if you press "Add to custom colors" before OK. If you don't press "Add to custom colors" then OK just closes the dialog. And if you do everything right, then your changes won't take effect until you restart Take Command.

It almost seems easier to edit the .INI file by hand. I've discovered that, although TCMD writes those values to the file as decimal, you can instead use hex with a leading 0x.
I appreciate the extra time and effort, Charles.

Chuck
 
#19
OK, my other laptop took a bath last week, so, I'm trying to set up again...

I copied over the JPSoft and JP Software folders, but I'm right back where I was: TCC's colors and fine, \but TCMD's are bright white on bright blue, instead of bright white on (dark) blue.

My memory may be failing, because I cannot figure or remember having to ultimately "do" anything to fix this .

So, how do I fix it again?

Regards,
Chuck Billow
 

Charles Dye

Super Moderator
Staff member
May 20, 2008
3,504
46
Albuquerque, NM
prospero.unm.edu
#20
Open your TCMD.INI file and find the [TabColors] section. Mine looks like this:
Code:
[TabColors]
TabColor00=0
TabColor01=8388608
TabColor02=32768
TabColor03=8421376
TabColor04=128
TabColor05=8388736
TabColor06=32896
TabColor07=12632256
TabColor08=8421504
TabColor09=16711680
TabColor10=65280
TabColor11=16776960
TabColor12=255
TabColor13=16711935
TabColor14=65535
TabColor15=16777215
Incidentally, Take Command writes these in decimal, but hex with a leading 0x works too. Makes 'em a lot more comprehensible, at least to my little brain.

If you want to modify the .INI file, say with a text editor, you may need to close all copies of Take Command first.
 
#21
OK Charles, mine shows

TabColor00=0
TabColor01=8388608
TabColor02=8388608
TabColor03=8388608
TabColor04=8388608
TabColor05=8388608
TabColor06=8388608
TabColor07=8388608
TabColor08=8421504
TabColor09=8388608
TabColor10=8388608
TabColor11=8388608
TabColor12=8388608
TabColor13=8388608
TabColor14=8388608
TabColor15=16777215

So...?
 
#23
If you have TCC looking as you like and want the same in TCMD, I'd suggest ...

Make sure TCMD is using the INI file you think it's using.

Get rid of (Edit\delete) the custom palette in the INI file. The palette you posted isn't very interesting.

TCMD ... Options ... TakeCommand ...Tabs ...Windows ... Colors: Foreground=Default, Background=Default. TCMD should then use the colors that are in the console.
 

Charles Dye

Super Moderator
Staff member
May 20, 2008
3,504
46
Albuquerque, NM
prospero.unm.edu
#25
OK Charles, mine shows

TabColor00=0
TabColor01=8388608
TabColor02=8388608
TabColor03=8388608
TabColor04=8388608
TabColor05=8388608
TabColor06=8388608
TabColor07=8388608
TabColor08=8421504
TabColor09=8388608
TabColor10=8388608
TabColor11=8388608
TabColor12=8388608
TabColor13=8388608
TabColor14=8388608
TabColor15=16777215

So...?
Looks like you have the blues! Close all instances of Take Command, open that file up in a text editor, and delete the entire [TabColors] section.
 
#26
OK, I deleted all the TCMD.ini files, and now

The TCC window looks fine. The TCMD window sows everything except that the colors still show what seems to be bright with on bright blue instead of bright white on(dark/plain) blue.
 
#30
CW, please try this. TCMD ... Options ... TakeCommand ... Tabs ...Windows ...TabColors ... post an image of this (shown below is mine, the defaults).

1524161498456.png

Also, please issue this command.
Code:
v:\> dir /a: /s /f c:\tcmd.ini
If you get more than one tcmd.ini, do this (in TCC and in TCMD)

Code:
echo %_ininame