By registering with us, you'll be able to discuss, share and private message with other members of our community.

SignUp Now!

Crash (abort) during COPY on Windows 10

TCC/LE is a castrated variant of TCC v14, with some functionality changed to complete unusability. But it has an interactive command prompt.
TCC-RT is an actual version in development, but lacking interactive prompt.

For running batch files? Just use TCC-RT. For interactive console? Use something else. Something that is more functional, than a bare command prompt.
Has anyone found a solution for this?

On every system I have, including a brand new windows 10 system with a fresh OS install, typing a command like
copy /s * \tmp

will copy a few files, hang, and then abort.

This is with TCC/LE. I'd happily update my TCC purchase if that fixed it, but it doesn't.

I wish I could use Take Command, but I can't deal with the broken keyboard handling
Has anyone found a solution for this?
Hello. Yes, I mentioned one on October 8:

"3. I installed the old free version of TCC/LE (14.0) but x86, not x64. It's worked fine so far."

I've used it since then with no problems whatever. I'm not aware of any disadvantages of using x86 instead of x64. Recommended.
Thank you shedey! I was still having this crash problem in Feb 2023. I added tcc.exe as a process exception as you showed, and my copy commands now run correctly.