OSD loses ampersands in text

  • This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Charles Dye

Super Moderator
Staff member
May 20, 2008
3,483
44
Albuquerque, NM
prospero.unm.edu
#1
Code:
osd /time=3 /hcenter /font=40 This ^& That!
I think you're calling DrawText() without DT_NOPREFIX.


Priority: Millions are anxiously awaiting your fix to this earth-shakingly urgent bug! Or not.
 
Last edited:

Charles Dye

Super Moderator
Staff member
May 20, 2008
3,483
44
Albuquerque, NM
prospero.unm.edu
#3
You need to double the ampersands.
Per the DrawText() documentation, yeah. (And escape both ampersands, or strong-quote them or whatever.) But setting one more bit in the flags arg would disable this inappropriate feature.

And yes, I know that it's worked that way since day 1, and nobody has ever complained, or perhaps even noticed. Not hugely important, just a tiny improvement that would be trivial to make.